Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2576 closed defect (duplicate)

Video stream does not replace MHEG image when channel transitions from off-air to on-air (UK,ITV4)

Reported by: knowledgejunkie@… Owned by: danielk
Priority: minor Milestone: unknown
Component: dvb Version: 0.20
Severity: medium Keywords: dvb off-air on-air channel ITV4
Cc: Ticket locked: no

Description

Running r11417, I checked the revision logs and didn't see anything resembling this issue wrt current SVN.

I recorded the Paris-Tours cycling highlights last night, which was the first programme broadcast on ITV4 after going on-air at 1800. I have a couple of minutes of pre-roll which meant the recording started whilst the channel was off-air. The resulting recording showed the ITV4 MHEG image "ITV4 Starts at 6.00pm" as I would expect.

Whilst watching the recording today (or skipping forward until the actual program started), I noticed the audio stream started playing normally, but the video stream did not start at all, and the MHEG image was displayed. Interestingly, when I skipped forward through the recording to see whether the video would get displayed, I noticed that whilst the MHEG image persisted, whenever the aspect ratio of the underlying broadcast changed (the program was 4:3, the adverts 16:9), the AR of the MHEG image also changed accordingly.

If I stopped the video after the program had started, and then restarted playback from that bookmark, the recording displayed normally with audio and video.

Nick

Change History (2)

comment:1 Changed 14 years ago by Stuart Auchterlonie

Resolution: duplicate
Status: newclosed

Duplicate of #2311

comment:2 Changed 14 years ago by Stuart Auchterlonie

(In [11598]) Closes #2311, Refs #2576. Adds support for restarting the MHEG engine when requested by the broadcaster. This is used in the UK when channels transition from off air to on air.

Thanks to David Matthews for the patch.

Note: See TracTickets for help on using tickets.