Opened 13 years ago

Closed 13 years ago

#2604 closed enhancement (invalid)

Myth does not handle overlapping recordings on the same channel

Reported by: myth@… Owned by: Isaac Richards
Priority: minor Milestone: 0.21
Component: mythtv Version: 0.20
Severity: low Keywords:
Cc: Ticket locked: no

Description

Here in Australia the TV networks are regularly a few minutes off the scheduled times which necessitates the use of the start early/finish late options, however if two programs on the same channel that use these options are against each other it will cause an overlap and myth will switch to a second tuner (if available) instead of recording the overlap and sharing it with both shows.

(MythTV 0.19 & 0.20, debian-multimedia.org packages)

Change History (11)

comment:1 Changed 13 years ago by Isaac Richards

Resolution: invalid
Status: newclosed

Not a bug.

comment:2 Changed 13 years ago by anonymous

Resolution: invalid
Status: closedreopened

Yes it is a bug. It prevents sucessful recording of two channels with two tuners (or one channel with one tuner). It means to get accurate recordings of n channels you need 2n tuners (if all channels change shows at the same time).

The fix is fairly simple logic wise (create a temporary third show of the overlap and append/prepand it as appropriate to the others)

comment:3 Changed 13 years ago by Isaac Richards

Resolution: invalid
Status: reopenedclosed

comment:4 Changed 13 years ago by drvik at bigpond <.> net <.> au

I support the comments by the original poster.... I am also in Australia and find that with only 2 DVB-T cards I am unable to record 2 channels because of this overlap issue... maybe this should have been filed as a feature request instead....

comment:5 Changed 13 years ago by darkstarsword@…

I third the original poster's comments. I also find this highly annoying when recording two consecutive shows and have had to resort to scheduling a manual record of the entire timeslot just to be able to record both.

comment:6 Changed 13 years ago by pdbailey@…

Thing is, it's not a bug. The solution you are proposing may very well be a better approach, but that's not currently the expected behaviour for Myth, so it's an enhancement/feature request really, and not a bug to fix.

comment:7 in reply to:  6 Changed 13 years ago by jochen

there is a patch at ticket #1772 to write to more then one file from one card, wich should fix this but it's not for the newest mythtv and it still only a preview...

but it may be a start for someone who will fix this...

comment:8 Changed 13 years ago by willu.mailingLists@…

  • The bug reporter is for bugs, for feature requests, use the Wiki.
  • The bug reporter is not for discussion - use the dev mailing list. I wouldn't post here, but I want to leave the next point for future readers.
  • Look at the 'softpad' branch. I use it to to solve exactly this problem. If there is no overlap then you get the padding. If there is overlap then the padding is dropped. You may not get all the data in the right recording, but you should get the data (where possible).

comment:9 Changed 13 years ago by anonymous

Resolution: invalid
Status: closedreopened
Type: defectenhancement

comment:10 Changed 13 years ago by anonymous

Milestone: unknown0.21
Severity: mediumlow

comment:11 Changed 13 years ago by danielk

Resolution: invalid
Status: reopenedclosed

Feature request without patch.

Note: See TracTickets for help on using tickets.