Opened 14 years ago

Closed 13 years ago

#2610 closed defect (fixed)

mythbackend crashes in http server

Reported by: cro@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have a script running on two computers that does the functional equivelant of "wget http://192.168.6.10:6544/xml" (192.168.6.10 is my only backend machine). When mythbackend is idle these scripts run every 5 minutes, but when something is being recorded they run every minute.

Since upgrading to myth 0.20 mythbackend has crashed at seemingly random times. I've rebuilt myth with debugging enabled and run mythbackend under gdb. This points the finger (I think) at httpserver.cpp (backtrace to follow). As a test I ran the following fragment on both computers at the same time

while true; do wget -O /dev/null http://192.168.6.10:6544/xml; sleep 1; done

Within a few minutes the backend crashes every time.

Attachments (1)

gdb.txt (23.2 KB) - added by cro@… 14 years ago.

Download all attachments as: .zip

Change History (4)

Changed 14 years ago by cro@…

Attachment: gdb.txt added

comment:1 Changed 14 years ago by dblain

Looking at the backtrace, it looks like it's the lm_sensor code that is causing the problem.

I tested using the same while loop (without the sleep) from two remote terminals for 45 min without any issues. However, I DO NOT have lm_sensors enabled.

Hopefully, someone with knowledge of how lm_sensor works can take a look to see if it is coded properly.

comment:2 Changed 14 years ago by cro@…

I removed lm_sensors from my system, rebuilt the myth rpms with the lm_sensors requirements taken out and installed the result. I've run the while loop (without the sleep) from two machines for over half an hour now without a crash, so I think your supposition is correct.

comment:3 Changed 13 years ago by cpinkham

Resolution: fixed
Status: newclosed

This was fixed in [12568] in trunk and [12569] in -fixes. Ticket #2895 was a duplicate of this ticket and the patches were applied referencing and closing that ticket.

Note: See TracTickets for help on using tickets.