Opened 13 years ago

Closed 11 years ago

#2615 closed defect (invalid)

ivtv: Toggle Teletext Captions does not work

Reported by: barnasc Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When assigning the Toggle Teletext Captions (TOGGLETTC) action for the 'T' key, the Mythtv OSD subtitle page (default 888) is not displayed. Enabling the teletext menu via the OSD menu and selecting page 888 manually is working, so it's not a teletext problem. I'm using the IVTV drivers and a PVR250 card.

The patch below is a first attempt to resolve this issue by doing :

  • explicit check on the kTrackTypeTeletextCaptions type in tv_play.cpp

For the latter, it looks like the fancy calls to track descriptions and language tracks are not fully functional and therefore resulting in wrong values (page = 0?) and skiping the Teletext OSD display routine.

Martin

Attachments (1)

ivtv_captions.diff (1.5 KB) - added by barnasc 13 years ago.

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by barnasc

Attachment: ivtv_captions.diff added

comment:1 Changed 13 years ago by danielk

Owner: changed from Isaac Richards to danielk
Summary: Toggle Teletext Captions does not workivtv: Toggle Teletext Captions does not work
Type: patchdefect
Version: 0.20head

The patch does not look right, but keeping ticket open for problem description.

comment:2 Changed 13 years ago by barnasc

Guess you mean it breaks the DVB Teletext captions. Is the OSD message and page indeed extracted from the DecoderBase::GetTrackDesc?() and DecoderBase::GetTrackLanguageIndex?() functions? It looks like these routines do not function for IVTV Teletext caption.

Martin

comment:3 Changed 11 years ago by Dibblah

Status: newassigned

comment:4 Changed 11 years ago by danielk

Status: assignedinfoneeded

barnasc, Is this still a problem, and if so do you have a short sample of video displaying this problem?

"T"oggle teletext works with the limited set of samples that I have here.

comment:5 Changed 11 years ago by danielk

Resolution: invalid
Status: infoneededclosed

No info provided. (Given the age of this ticket, not surprising). If anyone does have a sample that would be useful, the issue is probably that Martin is in some country that uses a different page for closed captions than any of the pages we look at for captions.

Note: See TracTickets for help on using tickets.