Opened 14 years ago

Closed 14 years ago

#263 closed defect (fixed)

Channel Scan does not properly set visible flag

Reported by: danielk Owned by: danielk
Priority: minor Milestone: 0.19
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Appears to happen only with VCT...

Sent patch to Glen Dragon to get his vct.toString() to determine problem.

Work around is to set the channels as visible after scan.

Attachments (2)

patch-263-v1.patch (906 bytes) - added by danielk 14 years ago.
patch-263-v2.patch (1.2 KB) - added by danielk 14 years ago.
Fix for channels not observing FCC's July 1st PSIP mandate

Download all attachments as: .zip

Change History (10)

comment:1 Changed 14 years ago by danielk

Owner: changed from Isaac Richards to danielk
Status: newassigned

comment:2 Changed 14 years ago by danielk

Resolution: invalid
Status: assignedclosed

Never got results of vct.toString() from Glen. He did tell me one of his broadcasters was testing ATSC transmission when he did the scan. With only that information, my guess has to be that this wasn't a bug but a proper result when the transmission is off-line according to the ATSC tables.

comment:3 Changed 14 years ago by gdragon@…

Resolution: invalid
Status: closedreopened

Umm. I did send you the log that you asked for. I will see if I can find it again, or reproduce it tonight.

I don't believe that this is a problem with one single broadcaster, since it was 4 of them.

Changed 14 years ago by danielk

Attachment: patch-263-v1.patch added

comment:5 Changed 14 years ago by danielk

Milestone: 0.19

Can you do a scan with the attached patch and send me the same info, but please delete the channels in the DB first.

comment:6 Changed 14 years ago by gdragon@…

New Log -> http://www.jetcom.org/~gad/scan/newscan-0908-debug.log Resultant channels are the same as previous. I delete the channels for that sourceid before every scan.

comment:7 Changed 14 years ago by danielk

It looks like these channels are marked as being hidden in the channel guide. My guess is they got either got some kind of excemption to the July 1st PSIP mandate, or the FCC is just being really lax. I'll make a patch...

Channel #0 name(WUHF-DT) 31-1 mod(ATSC 8-VSB) cTSID(0x88d)

pnum(3) ETM_loc(1) access_ctrl(0) hidden(0) hide_guide(1) service_type(2) source_id(1) descriptors length(34) count(2)

Extended Channel Name Descriptor (0xa0) length(15) Service Location Descriptor (0xa1) length(15)

Changed 14 years ago by danielk

Attachment: patch-263-v2.patch added

Fix for channels not observing FCC's July 1st PSIP mandate

comment:8 Changed 14 years ago by danielk

Resolution: fixed
Status: reopenedclosed

(In [7215]) Fixes #263.

This unhides channels that don't provide guide data.

This also makes the chanid's a little more human readable when the channel seperator is not a n undescore and makes sure that they are more sane when a human readable chanid is not available.

Note: See TracTickets for help on using tickets.