Opened 13 years ago

Closed 13 years ago

#2632 closed defect (fixed)

Compile error in 11626 at gamesettings.cpp line 138

Reported by: anonymous Owned by: greg
Priority: minor Milestone: unknown
Component: mythgame Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

g++ -c -pipe -march=athlon-xp -I/usr/include/kde/artsc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -Wall -W -O3 -Wall -Wno-switch -fomit-frame-pointer -D_REENTRANT -DPIC -fPIC -D_GNU_SOURCE -DPREFIX=\"/usr/local\" -DMMX -Di386 -D_FILE_OFFSET_BITS=64 -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_PLUGIN -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/share/qt3/mkspecs/default -I. -I/usr/local/include -I/usr/kde/3.3/include -I/usr/local/include -I/usr/include -I/usr/X11R6/include -I/usr/include/qt3 -o gamesettings.o gamesettings.cpp gamesettings.cpp: In constructor 'Command::Command(const MythGamePlayerSettings?&)': gamesettings.cpp:138: error: unknown escape sequence '\;' make[2]: * [gamesettings.o] Virhe 1 make[2]: Poistutaan hakemistosta "/root/src/latest/mythplugins/mythgame/mythgame" make[1]: * [sub-mythgame] Virhe 2 make[1]: Poistutaan hakemistosta "/root/src/latest/mythplugins/mythgame" make: * [sub-mythgame] Virhe 2 mythtv:~/src/latest/mythplugins# svn up At revision 11626.

Attachments (1)

gamesettings.cpp (820 bytes) - added by anonymous 13 years ago.
suggested fix

Download all attachments as: .zip

Change History (2)

Changed 13 years ago by anonymous

Attachment: gamesettings.cpp added

suggested fix

comment:1 Changed 13 years ago by greg

Resolution: fixed
Status: newclosed

(In [11629])

Closes #2632. I couldn't actually reproduce it under gcc 3.3.4 or 3.3.5

but since the suggested fix didn't break it I'm commiting it anyway.

Note: See TracTickets for help on using tickets.