Opened 14 years ago

Closed 14 years ago

#2637 closed defect (duplicate)

Backend segfault when switching channels in livetv

Reported by: Jim Paris <jim@…> Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I am seeing frequent segmentation faults when switching between channels on my hdhomerun device. I can recreate the problem by just opening up live tv and hitting up/enter a few times. This seems to be a different from bug #2635, from the backtrace. This is with SVN rev 11613.

Attachments (2)

myth.log (38.4 KB) - added by Jim Paris <jim@…> 14 years ago.
gdb.txt (32.0 KB) - added by Jim Paris <jim@…> 14 years ago.

Download all attachments as: .zip

Change History (6)

Changed 14 years ago by Jim Paris <jim@…>

Attachment: myth.log added

Changed 14 years ago by Jim Paris <jim@…>

Attachment: gdb.txt added

comment:1 Changed 14 years ago by Jim Paris <jim@…>

I have verified the problem still exists in the latest svn trunk, r11638.

comment:2 Changed 14 years ago by danielk

Owner: changed from Isaac Richards to danielk

comment:3 Changed 14 years ago by Jim Paris <jim@…>

This seems to be triggered by switching to a bogus channel (where there is a lock on the multiplex, but no data corresponding to the channel.serviceid).

comment:4 Changed 14 years ago by danielk

Resolution: duplicate
Status: newclosed

Duplicate of #2664.

Note: See TracTickets for help on using tickets.