Opened 13 years ago

Closed 13 years ago

#2655 closed patch (fixed)

New duplicate check method 'smart'

Reported by: martin@… Owned by: Stuart Auchterlonie
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords: dupmethod duplicate check smart
Cc: Ticket locked: no

Description

I've created a new 'smart' duplicate check method. I normally use either subtitle, or description. Sometimes a series flips between using a subtitle, and not (particularly with the UK eit guide data!). 'Subtitle and description' is pretty useless for me, because a) if the subtitles are none existent then they don't match b) if subtitles are present they can be fouled by small differences in the description - the whole reason for using subtitle in the first place.

So, I created 'Subtitle then description (smart)'. This first checks the subtitles match, however, if no subtitle exists, then and only then will it check the description.

I've done a little testing, and it seems to work ok, and helps to iron out some of the inconsistencies caused by the uk eit data. Anyway... see how it goes. I've attached patches for trunk, but they apply to 20-fixes ok.

Mythweb patch also included, but you'll need to update your .lang file with a string for 'Subtitle then Description (smart)'. I updated the english one, but spooked the diff, so i left that out.

Attachments (6)

mythtvsmartdup.patch (4.0 KB) - added by martin@… 13 years ago.
mythwebsmartdup.patch (2.0 KB) - added by marttin@… 13 years ago.
mythtvsmartdup.2.patch (4.0 KB) - added by martin@… 13 years ago.
Updated patch remove '(smart)' from name and using op 'else'
mythwebsmartdup.2.patch (2.0 KB) - added by martin@… 13 years ago.
Updated patch remove '(smart)' from name and using op 'else'
smartdup3.patch (4.4 KB) - added by martin@… 13 years ago.
duplicate.patch (739 bytes) - added by mythtv@… 13 years ago.
patch to add "Never record" button.

Download all attachments as: .zip

Change History (24)

Changed 13 years ago by martin@…

Attachment: mythtvsmartdup.patch added

Changed 13 years ago by marttin@…

Attachment: mythwebsmartdup.patch added

Changed 13 years ago by martin@…

Attachment: mythtvsmartdup.2.patch added

Updated patch remove '(smart)' from name and using op 'else'

Changed 13 years ago by martin@…

Attachment: mythwebsmartdup.2.patch added

Updated patch remove '(smart)' from name and using op 'else'

comment:1 Changed 13 years ago by martin@…

Anyone testing this? For me it works great, but wondering about people in other regions / versions

comment:2 Changed 13 years ago by anonymous

Type: patchenhancement

comment:3 Changed 13 years ago by martin@…

I've been using this patch for a few weeks and it's been working very well. I use the new 'subtitle else description' for most programs and it helps a lot on UK EIT.

HOWEVER, it should not change the default method. This should stay as 'subtitle and description', otherwise you risk missing recordings accidentally (this has happened to me twice).

comment:4 Changed 13 years ago by Stuart Auchterlonie

Owner: changed from Isaac Richards to Stuart Auchterlonie

Agreed it should not change the default duplicate matching method as that is a local preference, but other wise looks okay.

comment:5 Changed 13 years ago by anonymous

Ok... perhaps I should change the default back to 'and'. It would be really useful to have an option to set the default method, because for me 'else' works better, and I've never had a case where it doesn't work.

Martin... could you give me an example of where it hasn't worked? I'm intrigued to know. Also, are you using EIT or the RT grabber?

Changed 13 years ago by martin@…

Attachment: smartdup3.patch added

comment:6 Changed 13 years ago by martin@…

Ok. Updated the patch for 12214, and now I've left the default method as 'Subtitle and Description' in both mythweb and mythtv. Hope this is ok.

Rgds

Martin

comment:7 Changed 13 years ago by martin@…

Oh... forgot to mention. It's now in a single patch instead of 2. Let me know if that's a problem.

comment:8 Changed 13 years ago by martin@…

Any chance of getting this patch committed? I've changed the default back to 'Subtitle and Description', so it shouldn't cause anyone any grief. Let me know if there is any issue holding it back.

Martin

comment:9 Changed 13 years ago by Stuart Auchterlonie

Martin, now that the series link functionality is in, can you see how that works with the stuff you record?

It mainly works on BBC channels since they are the main broadcaster of the required information.

Stuart

comment:10 Changed 13 years ago by Stuart Auchterlonie

(In [12808]) Refs #2655. Adds a new duplicate checking method "subtitle then description".

This uses the subtitle for the dup match if there is a subtitle. If the subtitle is empty then the description is used to do dup matching.

I haven't added the new method to mythweb, i'll leave that for xris to do.

This also adds a new string that will need translation.

Thanks to Martin Long for the original patch

comment:11 Changed 13 years ago by mythtv@…

Stuart,

The series link stuff seems to be working really well. Not so much for the monkies at BBC though:

title subtitle programid Kill It, Cook It, Eat It Beef fp.bbc.co.uk/35W3TE Kill It, Cook It, Eat It Lamb fp.bbc.co.uk/35W3TG Kill It, Cook It, Eat It Lamb fp.bbc.co.uk/35W3TF Kill It, Cook It, Eat It Lamb fp.bbc.co.uk/35W3TF

As it turns out both of the first 2 were beef, so I don't understand why they got seperate IDs - and the second was incorrectly labeled 'lamb'

Tonight's episode has been called 'pork', but it's I'd is 35W3TG, so it wasn't going to record, maybe it will be a repeat of beef, or even lamb, I don't know yet, but it seems they've totally screwed this one up. They don't appear to have a seriesID at all.

I had thought, although I don't know if this will still work, that seriesid and programid could be used together to detect parts of the same program (eg a film seperated by the news) as well as the usual duplicate matching. I think where only programid matches, it's a duplicate, but where both match, it's a continuation. My fear is that this doesn't fit the model used by other regions, in which case, might a new column be required: 'showingid' maybe, where the EIT series identifier would fit.

comment:12 Changed 13 years ago by mythtv@…

Stuart,

I've noticed a couple of things. Kill It, Cook It, Eat It, does have a programid for all but 1 showing, it's missing for that one for some reason. It's the Omnibus by the way. Also, the seriesid isn't being copied across to the oldrecorded table - only the default authority.

comment:13 Changed 13 years ago by mythtv@…

Yes... i think i'm right about the seriesid / programid stuff. A quote from pvruk:

'The BBC is currently supplying metadata to support series recording, alternate instance and split instance.'

Of course, the compatibility with the current myth model could be the limiting factor.

comment:14 Changed 13 years ago by Rob Smith

(In [13008]) Fixes #3130, Re #2655, this adds the "Subtitle Then Description" duplicate check to mythweb in the default and light templates

comment:15 Changed 13 years ago by Rob Smith

(In [13009]) Re #3130, Re #2655, this sets the default duplicate check back to "Subtitle and Description" from "Subtitle then Description"

comment:16 Changed 13 years ago by mythtv@…

Priority: minormajor
Type: enhancementpatch

I've added a patch to enable the "Never Record" button when using this dupmethod. It was missed as an oversight in the original patch, because I used mythweb to manage most of my scheduling.

Changed 13 years ago by mythtv@…

Attachment: duplicate.patch added

patch to add "Never record" button.

comment:17 Changed 13 years ago by anonymous

Priority: majorminor

comment:18 Changed 13 years ago by Stuart Auchterlonie

Resolution: fixed
Status: newclosed

(In [13181]) Closes #2655. Adds the "Never Record" option for shows that are scheduled using the duplicate checking method "Subtitle then Description"

Note: See TracTickets for help on using tickets.