Opened 13 years ago

Closed 12 years ago

#2668 closed defect (invalid)

Possible race condition / endless loop when going to Program Guide from LiveTV

Reported by: mythtv@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: stuartm Ticket locked: no

Description

Hi guys,

For a number of weeks now I have been experiencing a problem whereby every time I try to enter the program guide from LiveTV I get an endless loop of what looks like a video initialisation race condition of some kind.

I see a flipping and flickering between a black screen and the blue MythCenter? background and then a possible number of things could happen:

  1. The looping happens for a number of seconds and then I see the program guide without a preview video which almost always results in more endless looping when I exit the guide,
  2. The looping continues indefinitely until I kill the mythfrontend process,
  3. The frontend seg faults (rare),
  4. I get "Error encountered displaying video" (also rare).

That's about the best I can do to explain it.

The attached backtrace is from the 'middle' of the endless loop, after a number of threads have been spawned (numerous threads spawn and die during the looping. but I suspect that's the video system trying to start / display the preview video). I tried to CTRL-C after a bunch of threads had started.

I'm no expert at interpreting the backtrace, but I see a number of mutex waits around that could indicate race condition.

Perhaps if someone asks the right questions I'll be able to supply a better description, as I'm aware that this all very vague.

I normally use XVMC, but have tried with Standard and the same problem occurs.

Regards,

Johan.

Attachments (2)

gdb.txt (18.8 KB) - added by mythtv@… 13 years ago.
Backtrace
mythfrontend-debugging.log (21.8 KB) - added by mythtv@… 13 years ago.
frontend log with record,channel,siparser

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by mythtv@…

Attachment: gdb.txt added

Backtrace

Changed 13 years ago by mythtv@…

Attachment: mythfrontend-debugging.log added

frontend log with record,channel,siparser

comment:1 Changed 13 years ago by mythtv@…

Just noticed this bit in the log that I haven't seen before, seems to be happening each 'loop'. Anyone know what it means?

91 	2006-11-09 17:19:30.982 TV: Changing from None to WatchingLiveTV
92 	Unable to launch application
93 	nVidiaVideoSync::: Interrupted system call

comment:2 Changed 13 years ago by mythtv@…

I worked this one out - it's not a problem with the program guide as such.

Seems I had the 's' key bound in my jumppoints to LiveTV in Guide ... this causes the above video subsystem havoc when pressed while I'm already in LiveTV.

After removing the binding for the jumppoint the usual guide key binding from LiveTV is active and brings up the guide and display video just as nicely as I remember.

Still .. perhaps there needs to be some checks in the code for that jumppoint to detect whether the frontend is already in LiveTV before trying to reinitialise video?

comment:3 Changed 13 years ago by stuartm

Cc: stuartm added

comment:4 Changed 12 years ago by stuartm

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.