Opened 13 years ago

Closed 13 years ago

#2671 closed defect (invalid)

mythtv-setup's Retrieve Lineup in VideoSource is failing

Reported by: rcamara@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Distro: Fedore Core 3 Kernel: 2.6.15.1 MythTv? version: 0.20

I came from 0.18, then to 0.19 and updated to 0.20 about a month ago. I have 3 existing capture cards entries. I added a new firewire capture card and I'm able to record unencyrpted shows on DCT6200 via firewire on the command line.

Then I run mythtv-setup(via ssh) to create a new card in 2. Capture Cards. Then on 3. Video sources, I create a new DataDirect? entry. I put a new Description and my username/password and I click on Retrieve Lineups then it doesn't populate the DataDirect? lineup dropdown. Also, if I go to the old DataDirect? Entries I had before and I click on Retrieve Lineups, it will unpopulate the DataDirect? lineups dropdown.

Going back when I click on Retrieve Lineups, on the ssh screen, I get the message below:

Resolving datadirect.webservices.zap2it.com... 206.18.98.160 Connecting to datadirect.webservices.zap2it.com[206.18.98.160]:80... connected. POST data file missing: /tmp/mythtv_post_dAj2u6 HTTP request sent, awaiting response... 401 Unauthorized Connecting to datadirect.webservices.zap2it.com[206.18.98.160]:80... connected. POST data file missing: /tmp/mythtv_post_dAj2u6 HTTP request sent, awaiting response... 500 Internal Server Error 16:20:31 ERROR 500: Internal Server Error.

However, when I run mythfilldatabase manually, it runs fine for my old data direct entries. It is able to connect properly to the server using the same username/password.

I renamed /usr/bin/wget to /usr/bin/wget.real and created a new script with the same name, /usr/bin/wget.

[root @localhostp cat /usr/bin/wget #!/bin/sh echo $0 $1 $2 $3 $4 $5 $6 $7 $8 $9 $10 $11 $12 $13 $14 $15 > /tmp/zap2it

This is what I got when I clicked on Retrieve Lineups

[root @localhostp cat /tmp/zap2it /usr/bin/wget --http-user=xxxxxxxx --http-passwd=xxxxxxxx --post-file=/tmp/mythtv_post_Hrmlda --header=Accept-Encoding:gzip http://datadirect.webservices.zap2it.com/tvlistings/xtvdService --output-document=-

I modified the --http-user and --http-passwd above to xxxxxxxx for security reasons but I'm sure it is correct.

Attachments (1)

mythtv_post.txt (1.1 KB) - added by rcamara@… 13 years ago.
2 files in one from /tmp/mythtv_post* files

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by rcamara@…

Attachment: mythtv_post.txt added

2 files in one from /tmp/mythtv_post* files

comment:1 Changed 13 years ago by anonymous

Ok, here is a new update that I found out. I got it working from the command line.

/usr/bin/wget --http-user=xxxxx --http-passwd=xxxxx --post-file=/home/mythtv/mythtv_post_EHejas --header=Accept-Encoding:gzip http://datadirect.webservices.zap2it.com/tvlistings/xtvdService --output-document=-

The file I attached earlier was actually taken from my local file, /home/mythtv/mythtv_post_EHejas

So, manually executing the command from the console above will yield good result. There is no more 500 Internal Server Error. What I've noticed is that the /tmp/mythtv_post* temporary files gets deleted so quickly which results to wget not able to use it. So even if the wget's --post-file points to a path, it's going to receive a 500 Internal Server Error since the file is already gone. So what really happens is that, wget is sending an empty xml file.

comment:2 Changed 13 years ago by rcamara@…

Here is the latest update. I had suid bits turned ON on all /usr/local/bin/myth*. Running mythtv-setup as mythtv created permissions /tmp/mythtv_post* as

-rw------- 1 root mythtv 525 Nov 10 00:14 /tmp/mythtv_post_DcZJVc

Suggest that give group read permissions to the /tmp files to fix suid bit issues.

For now, I chowned mythtv:mythtv on /usr/local/bin/myth* which deleted all the suid bits. It fixed it.

You can now close the ticket but something to look out for.

Thanks!

comment:3 Changed 13 years ago by stuartm

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.