Opened 13 years ago

Closed 13 years ago

#2707 closed defect (invalid)

ffmpeg, mytharchivehelper report wrong fps for some .nuv files

Reported by: thrantastic@… Owned by: paulh
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Mytharchivehelper incorrectly reports some of my transcoded .nuv files as having a fps of 29.9167 when it is actually 29.97 by NTSC standard. This error results in audio sync issues when exporting the video with Mytharchive. I can fix the audio sync by hacking the mythburn.py script to always return a fps of 29.97, which pinpoints the incorrect fps as the cause.

Through some digging I found that mytharchivehelper gets its fps value from libavformat/utils.c, so the problem appears to be with ffmpeg. I don't know enough about the code to be sure, but perhaps ffmpeg revision 6544 fixes the problem?

I can supply a .nuv file affected by this (not all of them are) for testing if needed. Attached is the output of mytharchivehelper for an offending .nuv.

Attachments (1)

info.xml (423 bytes) - added by thrantastic@… 13 years ago.
xml output of mytharchivehelper

Download all attachments as: .zip

Change History (3)

Changed 13 years ago by thrantastic@…

Attachment: info.xml added

xml output of mytharchivehelper

comment:1 Changed 13 years ago by paulh

Owner: changed from Isaac Richards to paulh

comment:2 Changed 13 years ago by paulh

Resolution: invalid
Status: newclosed

Hopefully this will be fixed the next time Isaac resyncs with ffmpeg. If not reopen the ticket and I'll take another look at it.

Note: See TracTickets for help on using tickets.