Opened 13 years ago

Closed 13 years ago

#2736 closed defect (fixed)

Sub-Channels not getting correct programming guide info

Reported by: spamme@… Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I previous had error resolved by 11821 Channels 4-1 shows the same programming on both channels. Channels 10-1 to 10-7 claim to the same shows on see attached picture. It used to work about a week ago. I deleted the capture cards, input connectors, and data source. I re-added everything. mythfilldatabase says:


DataDirect?: Not adding channel WMVSDT (WMVS-DT)


The error message is repeated for 10 different channels. However, it refuses to say why, or what to do about it.

Attachments (2)

untitled.GIF (92.5 KB) - added by spamme@… 13 years ago.
Picture of the wrong data
2736-v1.patch (726 bytes) - added by danielk 13 years ago.
Potential fix

Download all attachments as: .zip

Change History (10)

Changed 13 years ago by spamme@…

Attachment: untitled.GIF added

Picture of the wrong data

comment:1 Changed 13 years ago by danielk

Owner: changed from Isaac Richards to danielk

What is your zip code and which listings under that zip code are you using?

I've seen reports of this on the mailing list, and I would like to try reproducing your lineup...

comment:2 Changed 13 years ago by spamme@…

53215

It was working fine a couple days ago.

comment:3 Changed 13 years ago by spamme@…

the xmltvid field listed on mythweb under channels settings is the same for all the 10-1 through 10-7 channels.

comment:4 Changed 13 years ago by spamme@…

The problem is worse. When I delete and re-scan, all the data in column named xmltvid are GONE. I had to manually re-enter EVERY CHANNEL's xmltvid. Grrrrrrrrrrr.

comment:5 Changed 13 years ago by danielk

Resolution: invalid
Status: newclosed

This issue appears to have been fixed on zap2it's side (they reverted to the old channel format).

Spamme's continuing problems appear to be due to user error, he's manually entering the xmltvid rather than letting mythfilldatabase do it. He's entering the same xmltvid's for the all the channels on the same transport which predictably gives him the same listings data for all those channels.

comment:6 Changed 13 years ago by david.asher@…

Resolution: invalid
Status: closedreopened

This is definitely still an issue. I can reproduce it. My zip code is 01590, which gives me 44-1,2,3,4 and 2-1,2 PBS stations. Consistently I see my first mythfilldatabase (with all xmltvid= in the channel table) give all subchannels the same xmltvid, and it also REMOVES the subchannels >1 from the zap2it listing. I'm going to try and debug it a little myself. If I can't figure it out I'll post logs.

comment:7 Changed 13 years ago by david.asher@…

Ok, it was changeset 11816, the portion which changes update_channel_basic to match channels if the freqid matches (lines 1897-1899).

After a full ATSC channel scan the channel table has blank xmltvid's but the freqid is filled in the same for each subchannel. Therefore the first subchannel (not necessarily subchannel 1) from datadirect fills in the xmltvid for all subchannel's, causing subsequent checks to no longer see the blank xmltvid.

I don't know the correct fix, as I assume the analog channel scanner will break with datadirect if I remove the freqid comparisons. I can verify, however, that commenting out lines datadirect.cpp:1897-1899 does restore functionality for ATSC channel scanning.

Changed 13 years ago by danielk

Attachment: 2736-v1.patch added

Potential fix

comment:8 Changed 13 years ago by danielk

Resolution: fixed
Status: reopenedclosed

(In [12948]) Fixes #2736. Fixes bug in DataDirect? setup of ATSC channels.

datadirect.cpp:update_channel_basic() was sometimes matching channels based on their frequency rather than the ATSC major and minor channels. Unfortunately, the better the DataDirect? listings were the worse MythTV would screew up. This simply adds a check to the freqid matching so that it is only used when the ATSC minor channel is '0' which in the ATSC standards means it is actually referring to an NTSC channel.

Note: See TracTickets for help on using tickets.