Opened 13 years ago

Closed 13 years ago

#2737 closed defect (duplicate)

Some 720p HDTV recordings play out of A/V sync.

Reported by: DannyCan@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I've had this problem for sometime now. They play fine with mplayer or in windows but when there played with the internal mythtv player it looses A/V sync.

When I try to demux them with projectx, it get tons of these errors repeating over and over again.

!> dropping GOP# 91 @ orig.PTS 12:57:38.016 (4199221491), errorcode: 20

!> Pics exp/cnt 15/15, inGOP PTS diff. 266ms, new Timecode 00:00:15.131

!> dropping GOP# 92 @ orig.PTS 12:57:38.633 (4199277047), errorcode: 20

!> Pics exp/cnt 15/15, inGOP PTS diff. 283ms, new Timecode 00:00:15.131

When I demux with videoredo, the video plays really fast and it looses sync so I am unable to convert the video to any other format with my tools.

I think the video is trying to play at a speed less then the reported 59.94 fps instead of containing duplicate frames. I have uploaded a sample video to my website for you to examine. "http://watto.gotdns.org/Harry Potter and the Prisoner of Azkaban - 2006-10-28, 7-00 PM.TS" I used Mpg2Cut2 to make the sample and I use the knoppmyth distro with the latest mythtv trunk only a few weeks old.

Change History (1)

comment:1 Changed 13 years ago by Janne Grunau

Resolution: duplicate
Status: newclosed

duplicate of #2498, Refs #2498

Note: See TracTickets for help on using tickets.