Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#2748 closed defect (fixed)

EPG screen doesn't work and breaks LiveTV

Reported by: anonymous Owned by: Stuart Auchterlonie
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

SVN 11835

When I press 's' in LiveTV, so EPG screen appears. This is also the case when I press 'm' and choose EPG in the menu.

When I press ESC, the screen goes black and no frontend menu appears. I have to restart the frontend.

Here are the last lines from the frontend log:

2006-11-28 22:09:52.108 TV: StopStuff?() -- end 2006-11-28 22:09:52.108 TV: Changing from WatchingLiveTV to None 2006-11-28 22:09:52.184 DPMS Reactivated.

Attachments (1)

2748.patch (358 bytes) - added by ryan.buschert@… 13 years ago.
Potential Patch

Download all attachments as: .zip

Change History (13)

comment:1 Changed 13 years ago by tino.keitel+mythtv@…

Version: 0.20head

comment:2 Changed 13 years ago by anonymous

I can confirm the bug. This wasn't happening in svn version 11831. This is the behaviour of mythtv I have seen:

I start mythbackend, run mythfrontend and go to Watch tv. EPG (EIT) guide appears as usual. I choose a channel to watch. While watching LiveTV I press 's': No guide appears. I press 'm' and choose program guide in the menu: No guide appears. I press 'Esc': I get a completely black screen. I had to kill mythfrontend by Ctrl-Alt-Esc.

I restart mythfrontend, go to watch tv. LiveTV appears when the program Guide should have appeared. Press 's': I get no guide. Press 'm' and choose program guide: I get no guide. I kill (Ctrl-Alt-Esc) mythfrontend.

I restart mythbackend and start mythfrontend. I go to Watch TV: Program guide appears. I choose a channel to watch tv. Press 's' and Guide doesn't appear. 'm' and choose program guide in the menu: Guide doesn't appear. Press Esc: black screen. I Ctrl-Alt-Esc kill mythfrontend.

This is the whole console output of the third run (the last paragraph):

jose@amd64:~$ mythfrontend 2006-11-28 22:14:36.909 Using runtime prefix = /usr/local 2006-11-28 22:14:36.954 DPMS is active. 2006-11-28 22:14:37.002 New DB connection, total: 1 2006-11-28 22:14:37.012 Connected to database 'mythconverg' at host: amd64 2006-11-28 22:14:37.015 Total desktop dim: 1280x1024, with 1 screen[s]. 2006-11-28 22:14:37.019 Using screen 0, 1280x1024 at 0,0 2006-11-28 22:14:37.040 Current Schema Version: 1170 2006-11-28 22:14:37.041 mythfrontend version: 0.20.20061113-1 www.mythtv.org 2006-11-28 22:14:37.041 Enabled verbose msgs: important general 2006-11-28 22:14:37.624 Total desktop dim: 1280x1024, with 1 screen[s]. 2006-11-28 22:14:37.625 Using screen 0, 1280x1024 at 0,0 2006-11-28 22:14:37.625 Switching to square mode (Retro) 2006-11-28 22:14:37.637 Using the OpenGL painter mythtv: could not connect to socket mythtv: No existe el fichero o el directorio 2006-11-28 22:14:37.638 lirc_init failed for mythtv, see preceding messages 2006-11-28 22:14:37.689 Joystick disabled. 2006-11-28 22:14:38.131 Loading from: /usr/local/share/mythtv/themes/default/base.xml 2006-11-28 22:14:38.572 Registering Internal as a media playback plugin. 2006-11-28 22:14:38.606 Registering MythDVD DVD Media Handler as a media handler ext() 2006-11-28 22:14:38.607 Mediamonitor: Adding /dev/hdc 2006-11-28 22:14:38.611 Mediamonitor: Adding /dev/fd0 no record for '/block/hdc/device' in database no record for '/block/hdc/holders' in database no record for '/block/hdc/queue' in database no record for '/block/hdc/slaves' in database no record for '/block/hdc/subsystem' in database 2006-11-28 22:14:38.642 Mediamonitor: AddDevice?() -- Not adding '/dev/hdc', it appears to be a duplicate. 2006-11-28 22:14:38.644 Registering MythDVD VCD Media Handler as a media handler ext() 2006-11-28 22:14:38.664 Registering MythGallery Media Handler 1/2 as a media handler ext() 2006-11-28 22:14:38.664 Registering MythGallery Media Handler 2/2 as a media handler ext(gif,jpg,png) 2006-11-28 22:14:38.665 MonitorRegisterExtensions?(0x100, gif,jpg,png) 2006-11-28 22:14:38.726 Using NV NPOT texture extension adding: ATA:1,0,0 -- DVD_RW ND-3540A 2006-11-28 22:14:38.828 Registering MythMusic Media Handler 1/2 as a media handler ext() 2006-11-28 22:14:38.829 Registering MythMusic Media Handler 2/2 as a media handler ext(ogg,mp3,aac,flac) 2006-11-28 22:14:38.829 MonitorRegisterExtensions?(0x40, ogg,mp3,aac,flac) 2006-11-28 22:14:52.420 Starting media monitor. 2006-11-28 22:14:54.766 New DB connection, total: 2 2006-11-28 22:14:54.767 Connected to database 'mythconverg' at host: amd64 2006-11-28 22:14:54.808 Connecting to backend server: 127.0.0.1:6543 (try 1 of 5) 2006-11-28 22:14:54.811 Using protocol version 31 2006-11-28 22:14:54.820 TV: Attempting to change from None to WatchingLiveTV 2006-11-28 22:14:54.821 Using protocol version 31 2006-11-28 22:14:55.207 DPMS Deactivated 2006-11-28 22:14:55.215 NVP: Disabling Audio, params(-1,2,44100) 2006-11-28 22:14:55.245 VideoOutputXv?: XvMCTex: Init failed 2006-11-28 22:14:55.246 VideoOutputXv?: XVideo Adaptor Name: 'NV17 Video Texture' X Error: BadMatch? (invalid parameter attributes) 8

Major opcode: 140 Minor opcode: 14 Resource id: 0x246

2006-11-28 22:14:56.400 Realtime priority would require SUID as root. 2006-11-28 22:14:56.401 TV: Changing from None to WatchingLiveTV 2006-11-28 22:14:56.452 XMLParse::LoadTheme? using /usr/local/share/mythtv/themes/Retro/ui.xml 2006-11-28 22:14:56.686 Video timing method: SGI OpenGL 2006-11-28 22:14:57.191 AFD: Opened codec 0x2010f40, id(MP3) type(Audio) XvMCWrapper: Could not load hardware specific XvMC library "#libXvMC.so.1". #libXvMC.so.1: no se puede abrir el fichero del objeto compartido: No existe el fichero o el directorio 2006-11-28 22:14:57.200 VideoOutputXv?: XvMCTex: Init failed 2006-11-28 22:14:57.200 VideoOutputXv?: XVideo Adaptor Name: 'NV17 Video Texture' X Error: BadMatch? (invalid parameter attributes) 8

Major opcode: 140 Minor opcode: 14 Resource id: 0x246

2006-11-28 22:14:57.891 AFD: Opened codec 0x20125f0, id(MPEG2VIDEO) type(Video) 2006-11-28 22:14:57.899 Opening ALSA audio device 'default'. ALSA lib control.c:910:(snd_ctl_open_noupdate) Invalid CTL /dev/mixer 2006-11-28 22:14:57.908 AudioOutput? Warning: Mixer attach error -2: No existe el fichero o el directorio

Check Mixer Name in Setup: '/dev/mixer'

2006-11-28 22:14:57.909 NVP: Enabling Audio [mpegts @ 0x2b0c5c8ebd40]Parser not found for Codec Id: 94212 ! 2006-11-28 22:15:02.069 WriteAudio?: buffer underrun 2006-11-28 22:16:12.712 AO: Using time stretch 0.9 2006-11-28 22:16:22.128 AO: Changing time stretch to 1 2006-11-28 22:16:39.847 AO: Changing time stretch to 1.1 2006-11-28 22:16:44.339 AO: Changing time stretch to 1 Unable to launch application 2006-11-28 22:18:19.194 New DB connection, total: 3 2006-11-28 22:18:19.195 Connected to database 'mythconverg' at host: amd64 2006-11-28 22:18:20.121 WriteAudio?: buffer underrun [mpegts @ 0x2b0c5c8ebd40]Parser not found for Codec Id: 94211 ! [mpegts @ 0x2b0c5c8ebd40]Parser not found for Codec Id: 94212 ! [mpegts @ 0x2b0c5c8ebd40]Parser not found for Codec Id: 94212 ! [mpegts @ 0x2b0c5c8ebd40]Parser not found for Codec Id: 94212 ! [mpegts @ 0x2b0c5c8ebd40]Parser not found for Codec Id: 94212 ! [mpegts @ 0x2b0c5c8ebd40]Parser not found for Codec Id: 94212 ! [mpegts @ 0x2b0c5c8ebd40]Parser not found for Codec Id: 94212 ! 2006-11-28 22:18:20.679 AFD: Opened codec 0xaf8320, id(MPEG2VIDEO) type(Video) 2006-11-28 22:18:20.679 AFD: Opened codec 0x20125f0, id(MP3) type(Audio) 2006-11-28 22:18:20.679 AFD: Opened codec 0x1fda590, id(MP3) type(Audio) 2006-11-28 22:18:20.680 AFD: Opened codec 0x1f82c80, id(DVB_SUBTITLE) type(Subtitle) 2006-11-28 22:18:57.485 TV: Attempting to change from WatchingLiveTV to None [mpeg2video @ 0x2b0c5cee6c90]ac-tex damaged at 13 18 [mpeg2video @ 0x2b0c5cee6c90]Warning MVs not available Unable to launch application 2006-11-28 22:18:57.693 TV: Changing from WatchingLiveTV to None 2006-11-28 22:18:57.793 DPMS Reactivated. Terminado

I think the problem lies in the line that says "Unable to launch application". I hope this helped. If you need further info, just ask for it. Best regards.

comment:3 Changed 13 years ago by anonymous

I am not sure if it occurs in 11831. I just checked out fresh 11830, compiled and I still see this problem. One can still see the EPG from the recording scheduler

comment:4 Changed 13 years ago by anonymous

The revision that I used before was 11787. This revision had aworking EPG screen.

comment:5 Changed 13 years ago by anonymous

Still happens at revision 12156 with a clean compilation.

comment:6 Changed 13 years ago by anonymous

Update from last post on this topic: I've deleted all the files mythtv, mythplugins and myththemes install, and reinstalled all again again. The bug is still there.

comment:7 Changed 13 years ago by ryan.buschert@…

I was having this problem too after upgrading to SVN 12156. The attached patch seems to fix it for me. It looks to me like the problem came in with changeset 11828 with the "nvp->IsNearEnd?" check on line 4971 of tv_play.cpp. With 12156 as is, if I pause LiveTV for a few seconds, then unpause, the program guide shows up fine.

Changed 13 years ago by ryan.buschert@…

Attachment: 2748.patch added

Potential Patch

comment:8 Changed 13 years ago by tino.keitel+mythtv@…

The patch solved the problem here.

Thanks!

comment:9 Changed 13 years ago by flo@…

Hi there, thank you very much - i can confirm this, too. works greate ;)

when will that be in svn-trunk?

greets from germany.

flo

comment:10 Changed 13 years ago by Stuart Auchterlonie

Milestone: unknown0.21
Owner: changed from Isaac Richards to Stuart Auchterlonie

I can reproduce this here.

comment:11 Changed 13 years ago by Stuart Auchterlonie

Resolution: fixed
Status: newclosed

(In [12173]) Closes #2748. Fixes EPG issues and not exiting correctly from live tv.

Thanks to Ryan Buschert for the patch.

comment:12 Changed 12 years ago by skamithi

(In [12971]) Closes #2748. Expand "action on playback exit" option to include Live TV. patch from neil mcbride.

Note: See TracTickets for help on using tickets.