Opened 13 years ago

Closed 13 years ago

#2763 closed defect (fixed)

Unable to stream from slave backend to remote frontend

Reported by: gtgj@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

(Using SVN rev 12168)

I am unable to stream from a slave backend when MasterBackendOverride? is set but the slave's recording directory is not (currently) mounted on the master backend nor the frontend. I am attaching "-v file" logs from the frontend, the master backend, and the slave backend.

I believe the problem is due to "pathname" getting clobbered in ProgramInfo::GetPlaybackURL() after RemoteCheckFile?() is called. I am attaching a patch which seems to fix the problem.

Attachments (2)

remote_check_file-r12168.log (6.1 KB) - added by gtgj@… 13 years ago.
logs from frontend, master backend, slave backend
remote_check_file-r12168.patch (614 bytes) - added by gtgj@… 13 years ago.

Download all attachments as: .zip

Change History (3)

Changed 13 years ago by gtgj@…

logs from frontend, master backend, slave backend

Changed 13 years ago by gtgj@…

comment:1 Changed 13 years ago by cpinkham

Resolution: fixed
Status: newclosed

(In [12174]) Fix a bug in remote streaming playback from a slave that was introduced in the Storage Groups patch.

Patch to remoteutil.cpp by Gregorio Gervasio, Jr.

Further changes by me in programinfo.cpp as a safety precaution.

Closes #2763.

Note: See TracTickets for help on using tickets.