Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2777 closed defect (fixed)

Jobqueue issue with mpeg2->mpeg4 transcodes

Reported by: Stuart Auchterlonie Owned by: cpinkham
Priority: minor Milestone: 0.21
Component: mythtv Version: 0.20
Severity: low Keywords: jobqueue
Cc: Ticket locked: no

Description

Having just reviewed the weekend's recordings, i've noticed that the recordings which normally have an mpeg2->mpeg4 transcode done to them have an issue.

First sign of the problem is in the log file where you normally get

JobQueue?: Transcode Finished: <program name> "<subtitle>": size (<profile>)

but instead only get

JobQueue?: Transcode Finished:

digging deeper the into the jobqueue table the transcodes that have this issue have args="RENAME_TO_NUV" and comment="".

Examining the recording files themselves shows that the transcode has completed and so has the rename to nuv. ie. it's completed

The only other data point of note is mythweb is showing the recordings with the size that they would be prior to the transcode.

Change History (3)

comment:1 Changed 13 years ago by Stuart Auchterlonie

Owner: changed from Isaac Richards to cpinkham

comment:2 Changed 13 years ago by cpinkham

Resolution: fixed
Status: newclosed

(In [12468]) Don't cache the result of ProgramInfo::GetPlaybackURL inside ProgramInfo?. This isn't call that much to require the speed increase and this caching was messing with places where the file might be renamed such as when the transcoder renames a file from .mpg to .nuv.

Closes #2777.

comment:3 Changed 13 years ago by cpinkham

(In [12469]) When a transcoding job finishes, update the JobQueue? status field whether the file can be found or not. This shouldn't happen anymore, but prior to [12468] which fixed #2777, these jobs would get hung in an odd state because the new file could not be found.

References #2777.

Note: See TracTickets for help on using tickets.