Opened 13 years ago

Closed 12 years ago

#2793 closed patch (fixed)

DiseqC input connection settings not saved in mythtv-setup

Reported by: michel@… Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: low Keywords: diseqc setup rotor
Cc: Ticket locked: no

Description

Revision 12241.
setup is one dvb capture card and in the diseqc setting a rotor with a lnb.
When defining an input connection for the card in the DVB-S wizard part the entered rotor position is never stored/saved into the database.
Following two patches solve this problem. Only which one should be used?:

  1. First patch solves it the easy way but could be situation specific only.
  2. Second patch solves in the right place I believe but could inpact other object which descent from the ConfigurationWizard? object.

Attachments (4)

patch1.diff (536 bytes) - added by michel@… 13 years ago.
Quick patch without affecting other objects
patch2.diff (1.0 KB) - added by michel@… 13 years ago.
2793-v1.patch (28.0 KB) - added by danielk 13 years ago.
DiSEqC setup changes
2793-v4.patch (14.1 KB) - added by danielk 13 years ago.
Updated patch

Download all attachments as: .zip

Change History (15)

Changed 13 years ago by michel@…

Attachment: patch1.diff added

Quick patch without affecting other objects

comment:1 Changed 13 years ago by danielk

Milestone: unknown0.21
Owner: changed from Isaac Richards to danielk

Changed 13 years ago by michel@…

Attachment: patch2.diff added

comment:2 Changed 13 years ago by danielk

Resolution: invalid
Status: newclosed

The DiSEqC settings are saved when you select the "Finish" button in the Capture Card Setup. This is how options should be saved, they should not be saved when you select "Cancel" or hit the ESC button to exit from the configuration screen.

comment:3 Changed 13 years ago by spam@…

Resolution: invalid
Severity: mediumlow
Status: closedreopened

Rotor position inputs are set in the "DTV device Configuration" screen within the 'input connections" menu. I can confirm that rotor positions are "NOT" being saved when the "Finish" button is selected. I have tested patch1, it fixes the rotor settings problem.

comment:4 Changed 13 years ago by michel@…

The problem is indeed in the DTV device Configuration screen which you can find below the "4. input connections" menu option and then the input on the dvb card you want to change. In this input connection wizard you have the dvb-s button which will bring you to the wizard to specify the angle of the rotor for this input. The angle for the rotor will not be saved in the revision spcified in this patch.
Maybe I did not specify the problem in the right place.
Happy to see someone else can confirm this bug.

comment:5 Changed 13 years ago by anonymous

Keywords: diseqc setup rotor added

Possible data point. If you change the angle, and then "channel scan" while in the DTV configuration screen" it will save the new position when you finish.

Changed 13 years ago by danielk

Attachment: 2793-v1.patch added

DiSEqC setup changes

comment:6 Changed 13 years ago by danielk

michel, spam, can you try the attached patch...

I'm assuming the problem is with the USALS config?

If so, I believe this fixes it, along with making some other changes.

comment:7 Changed 13 years ago by danielk

(In [12252]) Refs #2793. Makes ConfigurationDialog? inherit from Storage.

This makes the ConfigurationDialog? behave more like the class did before the settings refactor. For instance instead of calling cfgGrp->save() you can now just call save(), this makes extending the class simpler, since you can just reimplement save() when you want to change how a dialog is saved, not exec() and save().

comment:8 Changed 13 years ago by danielk

(In [12253]) Refs #2793. General cleanup of DiSEqC code.

This doesn't change functionality at all. This eliminates a couple global functions, and removes the need for including DiSEqC headers in the videosources header file.

Changed 13 years ago by danielk

Attachment: 2793-v4.patch added

Updated patch

comment:9 Changed 13 years ago by danielk

(In [12254]) Refs #2793. This should have been part of [12252], the libmythtv ABI was changed by that commit, this updates the binary revision and makes a needed update in mythgame.

comment:10 Changed 13 years ago by michel@…

patch 2793-v4.patch solves the problem.
I applied it to revision 12256 and it does save the angle for the rotor now.
Looks good to me.

comment:11 Changed 12 years ago by danielk

Resolution: fixed
Status: reopenedclosed

(In [12307]) Fixes #2793. Allows rotor positions to be saved and refactors UI for DiSEqC setup so that many switches and rotor positions can be supported without running out of screen space.

Note: See TracTickets for help on using tickets.