Opened 13 years ago

Closed 13 years ago

#2850 closed defect (fixed)

SVN 12348: recording .png thumbs from secondary backend don't make it into mythweb cache

Reported by: pest789 at gmail dot com Owned by: xris
Priority: minor Milestone: unknown
Component: mythweb Version: 0.20
Severity: medium Keywords: png cache zero-byte mythweb recordings
Cc: Ticket locked: no

Description

After updating both my fe/be boxes to SVN 12348 last night, the .png thumbnails from new recordings on the secondary box are showing up in the primary's mythweb/data/cache dir as zero-byte files.

The thumbnails are correctly generated and stored in the secondary's recordings dir. The problem appears to only be with copying them to the cache on the primary.

This causes black thumbnails in the standard SVN 12348 /mythweb/tv/recorded.php display. I use a modified tmpl/default/recorded.php to give myself links to .flv transcodes of my recordings, and my version throws:

"Error at /var/www/mythweb/modules/tv/tmpl/default/recorded.php, line 286: getimagesize(): Read error!"

I can help fix this if someone can give me a hint on what mechanism causes them to be copied from the recordings dir on the secondary to the mythweb/data/cache dir on the primary.

Change History (2)

comment:1 Changed 13 years ago by anonymous

I fixed this myself. Here's a patch you should apply to mythplugins/mythweb/modules/tv/includes/objects/Program.php:

378d377
<       $urlparts = parse_url($fileurl);
380,381c379
< //        $host     = $GLOBALS['Master_Host'];
<       $host     = $urlparts['host'];
---
>         $host     = $GLOBALS['Master_Host'];

comment:2 Changed 13 years ago by xris

Resolution: fixed
Status: newclosed

(In [12363]) Fix host/port detection for pixmap transfers. closes #2850

Note: See TracTickets for help on using tickets.