Opened 13 years ago

Closed 13 years ago

#2855 closed defect (invalid)

Cannot build MythMusic w/ AAC

Reported by: cwatson@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythmusic Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

In compiling -fixes for inclusion w/ KnoppMyth?, I cannot build MythMusic with AAC. I compile MythPlugins? with:

./configure --prefix=/usr --enable-all --disable-festival --enable-fftw --enable-sdl --enable-aac --enable-new-exif

However, after configuration is done, I see:

AAC support will not be included in MythMusic

As part of the output. The latest KnoppMyth? is build from Debian Sid (updated last about 4 weeks ago). I do have the -dev files for faac and faad. I even installed both from source and still get the same message about AAC not being built.

Qt:3.3.7-1 Linux:KnoppMyth (Debian Sid) gcc: 4.1.2 config.log: ./configure --prefix=/usr --enable-all --disable-festival --enable-fftw --enable-sdl --enable-faac --enable-new-exif MythTV:Library API version: 0.20.20060828-3 Source code version: 12353M Hardware:Dragon

Change History (3)

comment:1 Changed 13 years ago by Nigel

Hi Cesman.
Check line 399 of mythplugins/configure. It looks like libmp4ff is also needed?

comment:2 Changed 13 years ago by cwatson@…

Hi Nigel,

Yes, I checked this prior to opening the ticket. libmp4ff is in faad. However it isn't included in the -dev (which I didn't realize when I opened the ticket). So in theory (as I've not gotten mpeg4ip to compile), one has to build mpeg4ip then rebuild faad in order to get libmp4ff. Unfortunately it took me a great deal... To make a long strong short, still no libmp4ff. However less, I'm mistaken I now don't think this is a bug w/ MythPlugins?. Please feel free to close this ticket.

Regards,

Cecil

comment:3 Changed 13 years ago by paulh

Resolution: invalid
Status: newclosed

Seems to be a dependency problem - not a myth problem

Note: See TracTickets for help on using tickets.