Opened 13 years ago

Closed 12 years ago

#2856 closed defect (fixed)

mythfilldatabase --only-update-channels RESETS zap2it channel settings

Reported by: xris Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Not sure which zap2it xml command causes this to happen, and it's probably a zap2it bug, but this should at LEAST have a nasty warning in mfdb so users don't accidentally reset all of their channels to enabled when they mean to use --do-channel-updates.

Change History (7)

comment:1 Changed 13 years ago by danielk

Owner: changed from Isaac Richards to danielk

Was this connected to a digital card? It shouldn't reset the zap2it listings unless connected to a digital source. Zap2It had some problems with their digital listings in November and early December, but they fixed it and posted an apology and explanation in their forums three or four weeks ago.

If it was an analog source this is probably a MythTV bug and I'll need more details.. (Also, I assume this is also a problem with SVN head, not just 0.20, true?)

comment:2 Changed 13 years ago by xris

it's connected to a firewire source, which I guess would be digital.. but this happened in late december, and I remember it happing many times in the past. All I know is that if you run --do-channel-updates, the zap2it lineup suddenly has ALL channels selected.

comment:3 Changed 13 years ago by danielk

Milestone: unknown0.21
Version: 0.20head

Thanks. Firewire is a special case. It's a digital source without a channel scanner, so it should currently be treated like an analog source in mythfilldatabase. I'm actually working on adding a channel scanner for it in the mythtv-firewire branch which will make it a full fledged digital source, but I'm still having some problems with the firewire bus reset handler.

Give me a few weeks for the proper fix, but I'll try to fix the zap2it reset this week.

comment:4 Changed 13 years ago by danielk

xris, I can't reproduce this with 0.20-fixes or head.

Can you still reproduce this?

If so, can you attach the output of this:

mysql mythconverg -umythtv -pmythtv -e"select cardid,cardtype from capturecard; select cardinputid,cardid,sourceid from cardinput; select sourceid, name, xmltvgrabber, lineupid from videosource;"

comment:5 Changed 13 years ago by xris

Still happening. Sorry for the delay, apparently my mailbox filters aren't properly excluding things from my generic "other tickets" match.

+--------+----------+
| cardid | cardtype |
+--------+----------+
|      1 | FIREWIRE | 
|      6 | FIREWIRE | 
+--------+----------+
+-------------+--------+----------+
| cardinputid | cardid | sourceid |
+-------------+--------+----------+
|           1 |      1 |        1 | 
|           5 |      6 |        1 | 
+-------------+--------+----------+
+----------+---------+--------------+-----------+
| sourceid | name    | xmltvgrabber | lineupid  |
+----------+---------+--------------+-----------+
|        1 | Comcast | datadirect   | WA46429:X | 
+----------+---------+--------------+-----------+

comment:6 Changed 13 years ago by danielk

(In [12574]) Refs #2856. Fixes a bug in SourceUtil::IsUnscanable?(), this was always returning false, but there are two recorders which don't yet support channel scanning: Firewire, DBox2.

comment:7 Changed 12 years ago by xris

Resolution: fixed
Status: newclosed

That seems to have fixed it.

Note: See TracTickets for help on using tickets.