Opened 13 years ago

Closed 11 years ago

Last modified 11 years ago

#2867 closed defect (invalid)

MythVideo Internal player requires bob deinterlace, "Watch Recordings" viewing does not.

Reported by: mythtv-dev@… Owned by: Isaac Richards
Priority: minor Milestone: 0.22
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I'd like to use the Internal player in MythVideo? but if I turn bob deinterlace off I get the odd/even frames displayed in the wrong order 50% of the time. Pausing and playing corrects it 50% of the time. I never have this problem with LiveTV or recorded shows.

If I turn it on then the CPU usage goes up to ~70% and I get skipping so I'm stuck with xine which insists on ignoring some of my LIRC settings.

My system is a VIA M10000 frontend running Debian Etch with a real TV as the only output connected via S-video. The X res is 720x576 using the Xorg VIA driver and DRI so it's turning off the TV encoder hardware deinterlacer. Which is a good thing since it looks better without it.

MythTV comes from debian-multimedia.org and is version 0.20-svn20061209-0.1 if that helps.

I'm willing to try out any patches or SVN but don't expect snappy turn around since the frontend boots from a flash disk and I'll need to rebuld on the backend...

Change History (8)

comment:1 Changed 13 years ago by drvik@…

I can confirm this effect also... running DVB Pal 720x576 interlaced material on a CRT TV via RGBs using a custom modeline (1024x576@50Hz Interlaced)

Gentoo 2006.1 64 bit, nvidia 6150 M/B with nvidia 9629 drivers running latest SVN...

I've actually been looking at this problem myself and am trying to work out whether mythtv is trying to sync only to every 2nd (even) frame, such that all the other (odd) frames are not synced correctly... this could cause the judderring effect that I have been looking at all this time... I am happy to look at the code if someone can point me in the right direction (I know it's hiding in sync.cpp)

comment:2 Changed 13 years ago by Anduin Withers

Component: mythvideomythtv
Owner: changed from Anduin Withers to Isaac Richards

comment:3 Changed 13 years ago by mythtv-dev@…

I've been trying out some things and it seems to be a problem with DVD rips and not programmes recorded from TV and moved to MythVideo?. Some DVD rips are OK too, Two I know that do have the problem are "Baby Bright 2" and any of the Noddy videos. Both are CG cartoons so the judder shows up really well (no motion blur to hide behind.)

comment:4 Changed 12 years ago by stuartm

Status: newinfoneeded_new

Could you tell us if this is still an issue with 0.21-fixes or 0.21 when it is released?

comment:5 Changed 12 years ago by anonymous

Yes, it is. Sorry about the anon (forgotten password). I still need to turn on bob-deinterlace and then get jerky motion as it fails to get enough CPU. I've tried messing with the playback menu entries under "Video Scan" but nothing seems to work. It also scales the video up which makes the effect worse. I have a 4:3 screen and DVB-T for TV (which is 16:9)> I have the Zoom setting at "Full" but with this 4:3 DVD rip I have to set the Zoom to "Off" or it scales up. (This may be an other bug. I'm on -fixes in case anyone wants to try a patch.

comment:6 Changed 11 years ago by stuartm

Milestone: unknown0.22
Status: infoneeded_newnew
Version: 0.200.21-fixes

comment:7 Changed 11 years ago by stuartm

Resolution: invalid
Status: newclosed

Try another deinterlacer, linear might be less heavy. However this isn't really a bug, the videos need deinterlacing and that's all there is to say. The code paths aren't any different for recording or video playback.

comment:8 in reply to:  7 Changed 11 years ago by anonymous

Replying to stuartm:

Try another deinterlacer, linear might be less heavy. However this isn't really a bug, the videos need deinterlacing and that's all there is to say. The code paths aren't any different for recording or video playback.

The videos do not need de-interlacing. The display is an interlaced TV and it works great with interlaced material recorded off air (DVB-T). Keep this ticket closed though since reripping the DVDs with VLC seems to have fixed things. I guess the problematic streams have incorrect metadata embedded.

Note: See TracTickets for help on using tickets.