Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2894 closed defect (invalid)

FTA-only setting not respected when have a listings source

Reported by: toad@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The FreeToAir?-only box is respected if I tell myth to only use EIT data, or don't add a listings source. However, if I do add a listings source, it is not respected; myth adds every possible channel from the listings source: Channels I simply don't get (for example all the regional variants), channels which are not FTA, etc. In Watch TV, the non-FTA channels are listed, and when I switch to them I get partial lock and then the failed to lock message. The effect on the rest of the system is that it will try to record things on channels I don't get, and therefore miss things it could have recorded.

Myth *does* ask about each individual channel on the console when setting up the grabber, however at this stage I don't know what channels I get, so I said "all", assuming that myth would later check the list of tunable FTA channels against the list of grabbable channels (since a) it knows which channels are not FTA at scan time, since it works without a grabber, and b) it can connect the tunable channel to the grabbable channel, otherwise nothing would work).

I spent a considerable amount of time on this last week; fixing this would greatly reduce the setup time for mythtv, at least for me. I did eventually settle on using only the EIT data, with help from #mythtv-users , but if this is the standard solution it should be documented in the HOWTO (it isn't).

Please tell me if this is in fact a wishlist item; I will (grudgingly :) ) add it to the feature wishlist if that is the case. I do believe it would greatly reduce the time taken to set up myth for a *lot* of people, and thus make myth useful to more people, less of a source of frustration, and less of a source of people complaining on #mythtv-users . I am willing to test fixes; I don't really have time to learn my way around the myth code at the moment, but if this is contained within a few files I might have a look.

Change History (2)

comment:1 Changed 12 years ago by danielk

Resolution: invalid
Status: newclosed

Feature request without patch.

BTW This is almost implemented with DataDirect? listings, we already only add channels that are picked up in the scan and we will soon be able to find only channels which we can decrypt in the channel scanner.

comment:2 Changed 12 years ago by anonymous

I don't understand the latter; the scanner will only add decryptable channels because I told it to, and it is able to do this already, if I don't add a listings source. The problem is that it adds all channels - both non-FTA channels and channels not detected at all in the scan - this is fixed in SVN? I can't use DataDirect? as I am in the UK; I use tv_grab_uk_rt.

Note: See TracTickets for help on using tickets.