Opened 14 years ago

Closed 14 years ago

#290 closed defect (fixed)

dvbchanneleditor is not included in backend only build

Reported by: hp-mythtv.org@… Owned by: danielk
Priority: trivial Milestone: 0.20
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description (last modified by danielk)

If I want to build a BACKEND ONLY, the linker errors with references to DVBChannelEditor. Backend and frontend combined builds work.

main.o(.text+0xdd0): In function `SetupMenuCallback(void*, QString&)':
: undefined reference to `ChannelEditor::ChannelEditor()'
main.o(.text+0xdd8): In function `SetupMenuCallback(void*, QString&)':
: undefined reference to `ChannelEditor::exec()'
main.o(.text+0xddf): In function `SetupMenuCallback(void*, QString&)':
: undefined reference to `VTT for ChannelEditor'
main.o(.text+0xdeb): In function `SetupMenuCallback(void*, QString&)':
: undefined reference to `vtable for ChannelEditor'
main.o(.text+0xdf7): In function `SetupMenuCallback(void*, QString&)':
: undefined reference to `vtable for ChannelEditor'
main.o(.text+0xe03): In function `SetupMenuCallback(void*, QString&)':
: undefined reference to `vtable for ChannelEditor'
main.o(.text+0xe0a): In function `SetupMenuCallback(void*, QString&)':
: undefined reference to `VTT for ChannelEditor'
main.o(.text+0xe16): In function `SetupMenuCallback(void*, QString&)':
: undefined reference to `vtable for ChannelEditor'
main.o(.text+0xe36): In function `SetupMenuCallback(void*, QString&)':
: undefined reference to `VTT for ChannelEditor'

Change History (2)

comment:1 Changed 14 years ago by danielk

Description: modified (diff)
Milestone: 0.20
Owner: changed from Isaac Richards to danielk
Priority: minortrivial
Severity: mediumlow
Status: newassigned

Linking problem with MacOS X porting compile.

comment:2 Changed 14 years ago by danielk

Resolution: fixed
Status: assignedclosed

(In [7216]) Fixes #290.

The "bug" was caused by [7045], which made the setup a backend option without adding the channeleditor stuff to libmythtv.pro.

This commit adds the applicable files.

I'll just point out again that the --disable-backend/--disable-frontend _advanced_ options are in place only to help porting MythTV to other platforms, especially MacOS X. They are not intended nor designed for building "lite" versions of MythTV.

Note: See TracTickets for help on using tickets.