Opened 12 years ago

Closed 11 years ago

#2905 closed defect (worksforme)

fatel error in mythweb when selecting 'dont record' option

Reported by: steve@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythweb Version: 0.20
Severity: high Keywords:
Cc: Ticket locked: no

Description

when using the mythweb plugin and browsing to upcoming recordings. select a show in the future and hit the dont record button, I get a Fatal Error at /usr/share/mythtv/mythweb/includes/programs.php, line 633: Unknown schedule for this program's recordid: message. although if you select a program that is to be recorded 'today' it works fine.

Attachments (1)

upcoming.html (5.1 KB) - added by anonymous 12 years ago.

Download all attachments as: .zip

Change History (10)

Changed 12 years ago by anonymous

Attachment: upcoming.html added

comment:1 Changed 12 years ago by xris

Would help to know if this is with .20, .20-fixes or svn.

comment:2 Changed 12 years ago by anonymous

the latest ubuntu version which seems to be 0.20-svn20061209-0.1ubuntu1

comment:3 Changed 12 years ago by xris

Have you tried more than one future recording? I can't replicate this (granted, I'm using the full svn version).

comment:4 Changed 12 years ago by anonymous

ok in playing around with this some this morning I see more info now. if I try to change any normally scheduled recording all is well on any day. (ones made from clicking on a show in the tv listings or from the mythfrontend interface made from selecting a specific show) if I click on any manual but recurring show (one station I have doesnt get the correct program via zap2it so I have manual recordings) anytime past "tomorrow" in the future the web interface thinks but then doesnt change the status in the "upcoming recordings" section. in the "recording schedule" page it have changed though. If I select any manually enterted recording "today" or "tomorrow" I get the error page. when I get the error page I also get the line

2007-01-25 06:39:47.342 Reschedule requested for id -1.

in the mythbackend.log file.

but if you still cant reproduce the error based on this info I will rebuild everything from source and go on with life.

thanks much.

comment:5 Changed 12 years ago by xris

(In [13088]) re #2905, this should remove any errors when trying to access manual-recording entries that might overlap with real shows. Takes advantage of the manualid portion of the program table's primary key. It doesn't seem to help schedules be overridden to prevent certain things from recording, though, but I think this may be a backend bug

comment:6 Changed 12 years ago by xris

Owner: changed from xris to Isaac Richards

Isaac, let me know what you think. Feel free to toss it back to me if I'm misinterpreting something.

comment:7 Changed 11 years ago by Rob Smith

Status: newinfoneeded_new

comment:8 Changed 11 years ago by anonymous

the bug never resurfaced after going to the latest svn at the time. prolly can close this as outdated or not an issue or such. thanks

comment:9 Changed 11 years ago by xris

Resolution: worksforme
Status: infoneeded_newclosed
Note: See TracTickets for help on using tickets.