Opened 13 years ago

Closed 12 years ago

#2916 closed defect (fixed)

Internal DVD - screen displayed twice and compressed vertically

Reported by: bhuffman@… Owned by: skamithi
Priority: minor Milestone: 0.21
Component: mythdvd Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Some DVD Menus and the MPAA warning on some DVDs appear as one screen compressed and displayed twice in the vertical direction. This doesn't happen if de-interlacing is turned off.

Attachments (3)

disable_interlacing_in_dvdmenu.diff (1.5 KB) - added by skamithi 13 years ago.
output_polar_express (42.1 KB) - added by bhuffman@… 12 years ago.
ticket_2916_attempt2.diff (1.6 KB) - added by skamithi 12 years ago.
modify auto deinterlacing detection code. make it more sensitive for dvds so wthat progressive frames seen right after a series of interlaced frames is not deinterlaced. i can reproduce consistently with bobdeint filter and lord of the rings II. the FBI warning frame is a progressive frame and experiences the problem. workaround is still to disable bobdeint.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 13 years ago by skamithi

Owner: changed from Anduin Withers to skamithi

comment:2 Changed 13 years ago by skamithi

will play around with interlaced settings and the dvd menu. first i will disable interlacing completely for the dvd menu, and see how that goes.

comment:3 Changed 13 years ago by skamithi

Milestone: unknown0.21
Status: newassigned

Changed 13 years ago by skamithi

comment:4 Changed 13 years ago by skamithi

bhuffman, please test the attached patch.

comment:5 Changed 12 years ago by skamithi

(In [12575]) Refs #2916. internal dvd player: disable deinterlacing methods when in a dvd menu

comment:6 Changed 12 years ago by skamithi

Resolution: fixed
Status: assignedclosed

comment:7 Changed 12 years ago by bhuffman@…

Resolution: fixed
Status: closedreopened

This does not fix the problem for me; rather it moves the problem to a new location. I just watched "Over the Hedge" last night (after latest SVN update) and now the menu and MPAA warnings look normal, but the beginning of the movie (Dreamworks intro) is exhibiting the same behavior. I went into the OSD, selected video scan and re-selected (it was already selected) the "Detect" and that fixed the problem.

Unfortunately I do not remember what it was showing (I or P) before and after the selection. But perhaps this info will help you to determine what's going on.

comment:8 Changed 12 years ago by bhuffman@…

I'll check tonight when I get home to see if it changes from "I" to "P" (or vice versa) after hitting "Detect" again.

comment:9 Changed 12 years ago by bhuffman@…

Specifically, with "Over the Hedge", there is a slight flicker after the MPAA warning where you can see that screen also exhibiting the same effect (displayed twice but compressed vertically). It then proceeds to the main title which also exhibits this behavior. If I select the OSD and look at video scan, it's set to "Detect(P)" -- so apparently has determined this is progressive content, however it appears that de-interlacing is still being attempted. If I click on the "Detect" option again, the problem resolves itself. However, the menu item is still showing "Detect (P)" (progressive).

comment:10 Changed 12 years ago by skamithi

Resolution: worksforme
Status: reopenedclosed

i cannot reproduce this problem. probably something to do with bob deinterlacing function. if you figure it out and create a patch, i'll be glad to review it and commit it.

comment:11 Changed 12 years ago by bhuffman@…

:-( I'll see what I can do. However, if I'm unable to find a fix and it's going to be closed anyway, should the whole thing just be reverted? If you have an interlaced menu, shouldn't interlacing be on?

comment:12 Changed 12 years ago by bhuffman@…

Resolution: worksforme
Status: closedreopened

This happens in Polar Express and also Twister. I'm attaching the output from mythfrontend -v playback for "Polar Express." When I select "video scan" and re-select "Detect", you can see "Disabling deinterlacing" in the output, and this fixes the problem.

Changed 12 years ago by bhuffman@…

Attachment: output_polar_express added

comment:13 Changed 12 years ago by skamithi

Milestone: 0.21unknown

comment:14 Changed 12 years ago by foom@…

FWIW, I saw this recently, too (using trunk r12786), watching a James Bond DVD. But seemingly only when jumping into the middle of the film via the chapter selection, not when starting from the beginning.

comment:15 Changed 12 years ago by skamithi

Milestone: unknown0.21

Changed 12 years ago by skamithi

Attachment: ticket_2916_attempt2.diff added

modify auto deinterlacing detection code. make it more sensitive for dvds so wthat progressive frames seen right after a series of interlaced frames is not deinterlaced. i can reproduce consistently with bobdeint filter and lord of the rings II. the FBI warning frame is a progressive frame and experiences the problem. workaround is still to disable bobdeint.

comment:16 Changed 12 years ago by bhuffman@…

This fixed the issue for all the above mentioned films. Thanks!

comment:17 Changed 12 years ago by skamithi

Resolution: fixed
Status: reopenedclosed

(In [13056]) Closes #2916. internal dvd player: modify auto deinterlacing code. make it for sensitive for dvds so that progressive frames seen right after a series of interlaced frames is not deinterlaced. only affects bobdeint.

Note: See TracTickets for help on using tickets.