Opened 13 years ago

Closed 9 years ago

#2938 closed defect (duplicate)

Teletext subtitles with DVB-C not fully working

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: head
Severity: medium Keywords: teletext, subtitles
Cc: Ticket locked: no

Description

If I watch live or a recorded program from Canal+ channels in Finland (Welho cable operator), not every line from the teletext subtitles is shown, especially this happens when the subtitle lines should appear in fast pace (e.g. a dialogue). This bug only appears if I set the subtitle language to finnish or danish in Canal+ channels, swedish and norwegian subtitles work ok. In other channels finnish and danish teletext subtitles are shown correctly.

However if I demux a recording using ProjectX, full teletext subtitle tracks for finnish and danish are found. When the demuxed video+audio files are multiplexed back to mpeg2 using mplex and played with mplayer the subtitles in .sub format are shown correctly.

My system consists of Fedora 6 (kernel (2.6.18-1.2869), MythTV latest svn, Technotrend C1500 DVB-C cards and kernel dvb drivers.

Change History (9)

comment:1 Changed 13 years ago by otto at kolsi dot fi

I have seen similar problem couple of times, with DVB-T and YLE channels in Finland (with SVN HEAD). My colleague has also seen this with DVB-C and YLE channels.

What happens in my case is that for couple of "screens" the subtitles are missing and then VERY fast those missing subtitles are displayed and then it gets back to normal again.

My colleague mentioned that this "problem" is preserved in the recording, so that you should be able to reproduce it once it happens. So it's not a random problem during decoding.

comment:2 Changed 13 years ago by danielk

Version: 0.20head

You are talking about the textual subtitles, not the graphic ones, right?

The textual ones are shown as soon as the are decoded, see TeletextDecoder::Decode() in "libs/libmythtv/teletextdecoder.h" and the three different "ttd->Decode(" calls in "libs/libmythtv/avformatdecoder.cpp". If you want to improve the timing for these captions you will need to synthesize a "pts" timestamp for the captions and add that timestamp to the TeletextReader::AddTextData?() call which the TeletextDecoder? uses to pass the data to the NuppelVideoPlayer?. The NVP already has support for timecodes for other types of AddXXXData() calls, it shouldn't be too hard to modify the NVP.

comment:3 in reply to:  2 Changed 12 years ago by t-p@…

Replying to danielk:

You are talking about the textual subtitles, not the graphic ones, right?

Yep, textual teletext subtitles doesn't work fully, textual dvb subtitles however on other channels work ok.

comment:4 Changed 11 years ago by anonymous

Got a similar problem with the norwegian teletext subtitles on Canal+ channels. Lots of lines are skipped. Norwegian is selected as default language. Switching to swedish teletext subs work fine.

Also, and more importantly, the channels in question transmit dvb subtitles as verified by using vdr, but these are not available in mythtv.

It seems like like the teletext-subtitles somehow get preference above the (much better) dvb subtitles.

Canal+ HD haven't got teletext subtitles and thus show the dvb subtitles correctly.

comment:5 Changed 10 years ago by stuartm

Component: mythtvMythTV - Video Playback

comment:6 Changed 10 years ago by sperwer

Got a similar problem with the danish teletext subtitles on Canal+ channels. Lots of lines are skipped. daish is selected as default language.

Also, the subtitles are horizontally located to the left and vertically located in the center of the screen.

Canal+ HD shows the dvb subtitles correctly.

comment:7 Changed 10 years ago by stuartm

Unless you have something useful to add, do not comment on tickets.

comment:8 Changed 9 years ago by anonymous

Same problem with DVB-S streams. Canal+ (Finland). Finnish subtitles.

comment:9 Changed 9 years ago by Dibblah

Resolution: duplicate
Status: newclosed

Duplicate of http://svn.mythtv.org/trac/ticket/7515

Which has a patch.

Note: See TracTickets for help on using tickets.