Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2975 closed task (fixed)

Remove pcHDTV V4L DTV support

Reported by: danielk Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Almost everything you could do with the digital V4L drivers can be done with the DVB drivers, and the digital V4L driver has not been actively maintained for a while now.

Attachments (3)

2975-v1.patch (59.9 KB) - added by danielk 12 years ago.
Removal patch (must mark {pc,}hdtv*.{h,cpp} for deletion bfr commit)
2975-v2.patch (59.9 KB) - added by danielk 12 years ago.
Updated patch
v4l1_setformat_fallback.patch (407 bytes) - added by David George <david@…> 12 years ago.
set v4l1 fallback if v4l2 format change fails

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by danielk

Attachment: 2975-v1.patch added

Removal patch (must mark {pc,}hdtv*.{h,cpp} for deletion bfr commit)

Changed 12 years ago by danielk

Attachment: 2975-v2.patch added

Updated patch

comment:1 Changed 12 years ago by danielk

Resolution: fixed
Status: newclosed

(In [14444]) Fixes #2975. Removes pcHDTV V4L driver support.

No one was using this anymore when I asked about it about 9 months ago... The pcHDTV HD-2000 and HD-3000 cards have been supported by the Linux DVB drivers for some time now.

comment:2 Changed 12 years ago by David George <david@…>

This commit has a regression for me. Just wanted to send this in case anyone has the same problem.

I have a mixture of DVB and IVTV cards and I use the S-Video input on the ivtv cards for capturing from satellite STB. With this commit the v4l2 SetInputAndFormat?(9, ATSC) fails then the fallback to v4l1 is never called which causes my externalcommand to never be called. I have added the usingv4l1 = 1 back in if ioctl VIDIOC_S_STD fails and my external changer is working again. I have the TVFormat in the channel editor for the satellite channels to default which I wouldn't think should be used because they come in via s-video and the TVFormat for the OTA channels as ATSC. I also have TVFormat in my General settings set to ATSC.

Probably the real fix for this is to not bother trying to set the v4l format unless the inputname starts with 'Tuner' (and possibly Antenna or Television for other v4l cards?). I will work on a patch to do this, but my time is limited and my above fix takes care of my immediate issue.

comment:3 Changed 12 years ago by danielk

Resolution: fixed
Status: closedreopened

comment:4 Changed 12 years ago by David George <david@…>

I am attaching a patch that re-enables v4l1 fallback so that the external channel changer in externalcommand will run even if your default TVFormat is ATSC.

Changed 12 years ago by David George <david@…>

set v4l1 fallback if v4l2 format change fails

comment:5 Changed 12 years ago by danielk

Resolution: fixed
Status: reopenedclosed

David, ATSC is an invalid TV format for capturing using the analog ivtv card. Setting the TV format for the video source to the appropriate PAL, SECAM, or NTSC format as should fix the reported problem.

This usingv4l1 fall-back hack was only added because the first pcHDTV HD-2000 v4l driver was a v4l2 driver except for this one aspect where it required one v4l1 call. The ivtv drivers do not require this hack, I think you were simply able to get away with a incorrectly configured tvformat because of bugs in the old v4l1 interface.

We can't get rid of the format call in the absence of a tuner because it tells the hardware how to decode the signal. If you are in Luxembourg you need to tell the hardware whether to decode the channel as PAL or SECAM on a per channel basis; without setting the standard you would, at best, get B&W images with the wrong standard configured.

comment:6 Changed 12 years ago by danielk

(In [14885]) Refs #2975. Removes two settings pertaining to pcHDTV V4L tuning, and moves the HDRinbufferSize setting from mythfrontend to mythtv-setup.

Note: See TracTickets for help on using tickets.