Opened 13 years ago

Closed 13 years ago

#2977 closed patch (fixed)

id3v1 tags not removed and id3v2 tags not added

Reported by: myth@… Owned by: stuartm
Priority: minor Milestone: 0.21
Component: mythmusic Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If you have an mp3 file with a id3v1 tag, and you edit the metadata, the id3v1 is left unaltered (although source code comment suggests that it should have been removed) and changes are only stored in the id3v2 tag. And if there was no id3v2 tag, the new metadata is not written.

Attached patch fixes both issues ;

  • insert v2 tag if no tag exists
  • if writing v2 tag and v1 tag exists, truncate file at v1 tag.

Attachments (1)

id3tag.patch (3.9 KB) - added by myth@… 13 years ago.
patch for bug

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by myth@…

Attachment: id3tag.patch added

patch for bug

comment:1 Changed 13 years ago by stuartm

Milestone: unknown0.21
Owner: changed from Isaac Richards to stuartm
Status: newassigned

comment:2 Changed 13 years ago by stuartm

Eskil, it appears id3v2 tags are being written to the start of the file, but they aren't readable by any id3 tag readers. I'm guessing they aren't formatted correctly. I've not found the cause yet, and I'm not even sure if the problem existed prior to this patch but I thought I should mention it.

comment:3 Changed 13 years ago by stuartm

Never mind, user error, I was testing using apps which don't support ID3v2.4 tags. Surprisingly difficult to find anything supporting v2.4 to test with.

comment:4 Changed 13 years ago by stuartm

Resolution: fixed
Status: assignedclosed

(In [12722]) Closes #2977

Apply patch by Eskil to remove ID3v1 tags and allow insertion of new ID3v2 tags.

Note: See TracTickets for help on using tickets.