Opened 12 years ago

Closed 11 years ago

#3000 closed defect (fixed)

internal dvd player: dvd fails to play after changeset 12645

Reported by: skamithi Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

danielk tracked down the issue. the current patch is to revert most of the changes to libformat/mpeg.c

Attachments (3)

dvd-fix.patch (3.6 KB) - added by skamithi 12 years ago.
ticket_3000.diff (7.0 KB) - added by skamithi 12 years ago.
danielk found out that actually the root cause is the url_fseek call that was added in ffmpeg changeset 7560. preventing avf_seek from been called for a dvd resolves the issue as well. So far haven't seen any harm in leaving it this way. Also fixed some compiling warnings in avformatdecoder.cpp
dvd_ds9_menufail.log.bz2 (3.9 KB) - added by g8ecj@… 12 years ago.
log of DVD menu failure

Download all attachments as: .zip

Change History (10)

Changed 12 years ago by skamithi

Attachment: dvd-fix.patch added

comment:1 Changed 12 years ago by skamithi

Owner: changed from Isaac Richards to skamithi

comment:2 Changed 12 years ago by danielk

(In [12659]) Refs #3000. Reverts ffmpeg changeset 7562 brought in by ffmpeg sync [12645].

According to what Stanley Kamithi has been able to dig up this was a code cleanup patch, but it has broken DVD playing in MythTV. I believe the problem is that the new code doesn't set timecodes properly, but it's a bit complicated so I'm just reverting the change for now.

Changed 12 years ago by skamithi

Attachment: ticket_3000.diff added

danielk found out that actually the root cause is the url_fseek call that was added in ffmpeg changeset 7560. preventing avf_seek from been called for a dvd resolves the issue as well. So far haven't seen any harm in leaving it this way. Also fixed some compiling warnings in avformatdecoder.cpp

comment:3 Changed 12 years ago by skamithi

Owner: changed from skamithi to Janne Grunau

comment:4 Changed 12 years ago by Janne Grunau

Version: 0.20head

comment:5 Changed 12 years ago by skamithi

(In [13709]) Refs #3000. Refs #3611 internal dvd player. after the last ffmpeg resync [13655], the problem described in #3000 reappeared. commiting suggested fix by janneg. may also resolve #3611.

Changed 12 years ago by g8ecj@…

Attachment: dvd_ds9_menufail.log.bz2 added

log of DVD menu failure

comment:6 Changed 12 years ago by g8ecj@…

I've been unable to play Region 4 DS9 DVDs since changeset [13655]. This log is from [13756] (svn sync on Saturday) and it still kicks out before the initial title sequence starts.

comment:7 Changed 11 years ago by Janne Grunau

Resolution: fixed
Status: newclosed

this should be fixed since [13709]

Note: See TracTickets for help on using tickets.