Opened 13 years ago

Closed 13 years ago

#3010 closed defect (wontfix)

Mythweb listings/details page, 'on mouseover' , pop-up blinks when contents are too large

Reported by: graybeard@… Owned by: xris
Priority: minor Milestone: unknown
Component: mythweb Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Fedora core 6

mythweb-0.20-150.fc6.at.rpm

Firefox 1.5.0.9 browser: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.9) Gecko/20061219 Fedora/1.5.0.9-1.fc6 Firefox/1.5.0.9 pango-text

Sea Monkey 1.0.7 browser: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.9) Gecko/20061223 Fedora/1.0.7-0.6.fc6 pango-text SeaMonkey?/1.0.7

Preparation: Open mythweb listings page, see "Bstargalactica-Hoverbug.tar.gz" attachment, file 'hover-blink.html'. The same bug as found on the details page is in, "Bstargalactica-details-hoverbug.tar.gz", file 'Details-blink.html'

Problem: When using the mouse over feature on a show listing link (in this case "Battlestar Galactica: Sacrifice"), the pop-up description will rapidly blink if the contents of the pop up are too great. At times, scrolling the page up will allow the pop-up to display correctly in the lower half of the browser, instead of rapidly blinking in the top half.

I've just noticed that this also happens on the detail page, if the 'Possible conflicts with this show:' pop-up link has the same content. See attachment and the link at 'Possible conflicts with this show: Battlestar Galactica: Sacrifice'

The attachment .tar.gz files have the relevant pages saved as 'Complete web page's, which will hopefully allow for the reproduction of this bug.

Expected Behaviour: Pop-up window will open fully, without rapidly blinking on and off and making it unreadable. The image attachment "details-blink-upper.png" is a momentary snapshot of the pop-up (between blinks) on the listings page, as it should appear.

Reproducable: Only on 'large content' pop-ups, small pop-ups always display correctly. Occasionaly scrolling the page will 'fix' the problem.

Attachments (3)

Bstargalactica-Hoverbug.tar.gz (44.2 KB) - added by graybeard@… 13 years ago.
Bstargalactica-details-hoverbug.tar.gz (43.5 KB) - added by graybeard@… 13 years ago.
details-blink-upper.png (105.1 KB) - added by graybeard@… 13 years ago.

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by graybeard@…

Changed 13 years ago by graybeard@…

Changed 13 years ago by graybeard@…

Attachment: details-blink-upper.png added

comment:1 Changed 13 years ago by xris

Resolution: wontfix
Status: newclosed

Nothing I can do about this. The popup appears because of a mouseover event. When it appears over the generating element, it steals focus, and the parent element's mouseout is triggered, hiding the popup, which causes another mouseover, etc, etc.

This may get fixed at some point in the future when I redesign the mouseover/popup code but for now, there's not much I can do about it.

Note: See TracTickets for help on using tickets.