Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#3011 closed defect (fixed)

importing channels.conf does not work since revision 11682

Reported by: mythtv@… Owned by: janne
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by janne)

Importing the channels.conf file generated by dvbscan tools does not work anymore.
In the logging the message is listed that channels are imported, but none of them are stored in the database for some unclear reason. No error-message is given at all. Channels are just all ignored, not even 'skipped' mesages are displayed in the setup.
After this error of importing automaticly the scanner is started, tuning for channels, but it cannot lock anything.

To me, it seems a different problem that ticket #2830. The channel.conf files are generated as is, by dvbscan tooling. And even if the format is invalid and this quirky behaviour is by design, the setup tool should mention what is incorrect in the channels.conf files, at least in the logfiles. But: before revision 11682 my channel.conf files, work, and from 11682 and on it they do not, so I do NOT believe the channel.conf files are wrong.

I use DVB-S, on the Astra 1, 2 and Hotbird satellites. I live in the Netherlands. (MPEG2)

Attached I have put my channels.conf files (generated by dvbscan) and a logfile of mythtv-setup.

Attachments (4)

myfiles.tgz (20.6 KB) - added by mythtv@… 7 years ago.
channels.conf (29 bytes) - added by anonymous 7 years ago.
channels.2.conf (29 bytes) - added by anonymous 7 years ago.
mythsetup.log (5.5 KB) - added by mythtv@… 7 years ago.

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by mythtv@…

comment:1 Changed 7 years ago by danielk

  • Owner changed from ijr to danielk
  • Version changed from 0.20 to head

Here's where things go awry:

2007-01-12 12:15:14.631 SIScan(0): Tuning to 0 mplexid(0)
2007-01-12 12:15:14.631 SM(0)::AddFlags: Seen() Match() Wait(Pos,)
2007-01-12 12:15:14.631 DiSEqCDevTree: Changing LNB voltage to 13V
2007-01-12 12:15:14.695 DiSEqCDevTree: Changing to DiSEqC switch port 2/4
2007-01-12 12:15:14.695 DiSEqCDevTree: Sending DiSEqC Command: e0 10 38 f4 
2007-01-12 12:15:15.180 DVBChan(0): Old Params: 0 auto a auto auto a a auto a v
			DVBChan(0): New Params: 0 auto a auto auto a a auto a v
2007-01-12 12:15:15.180 DVBChan(0): Tune(): Tuning to 9750000kHz
2007-01-12 12:15:15.180 dvbchannel.cpp:wait_for_backend: Status: 
2007-01-12 12:15:15.180 DVBChan(0): Tune(): Frequency tuning successful.
2007-01-12 12:15:15.180 DTVSM(0)::SetChannel(-1, -1): 
2007-01-12 12:15:15.181 SM(0)::Start: begin
2007-01-12 12:15:15.181 SM(0)::Start: end
2007-01-12 12:15:18.085 SIScan(0): Stopping SIScanner
2007-01-12 12:15:18.085 DVBSM(0)::Stop: begin
2007-01-12 12:15:18.085 SM(0)::Stop: begin
2007-01-12 12:15:18.110 SM(0)::Stop: end
2007-01-12 12:15:18.110 DVBSM(0)::Stop: end
2007-01-12 12:15:18.110 SIScan(0): SIScanner Stopped
2007-01-12 12:15:18.110 DVBSM(0)::Stop: begin
2007-01-12 12:15:18.110 SM(0)::Stop: begin
2007-01-12 12:15:18.111 SM(0)::Stop: end
2007-01-12 12:15:18.111 DVBSM(0)::Stop: end
2007-01-12 12:15:18.111 SM(0)::Stop: begin
2007-01-12 12:15:18.111 SM(0)::Stop: end
2007-01-12 12:15:18.111 DVBChan(0): Closing DVB channel
2007-01-12 12:15:18.111 DVB#0 CA: CiHandler thread stopped
2007-01-12 12:15:18.111 ~ScanProgressPopup()
2007-01-12 12:15:18.908 SetPage(Scan Configuration)

For some reason the scan stops after looking at just one frequency. I will need to add some debugging statements to the code to figure out why this is failing.

comment:2 Changed 7 years ago by mythtv@…

Uuh, it might be that I stopped the scan by hand in this logging...
If I do not do that, the scanner is scanning for hours, only waiting for timeouts, and finally come up with no channels...

Because you say that the first error in the logging is a stop of tuning, do I understand it correctly that it is now by design that the tuner start scanning for channels it already has imported? If so, do I need to produce a logging of these timeouts?

comment:3 Changed 7 years ago by danielk

Uhm, if you cancel the scan immediately no channels will be inserted.

Please try importing just one channel you know you should be able to get and let it scan without cancelling the import, attach the log & channel.conf from that.

The import just seeds the channel scanner. The timeout for DVB-S is by default very conservative, something like 40 seconds. This is why it takes so long. If you only scan one rotor position at a time you should be able decrease this to 1 second for the signal lock, and 4 seconds for the channel lock during the scan. Once we apply the patch in #2802 we can decrease the lock timeout and only use this timeout once the rotor has turned.

comment:4 Changed 7 years ago by mythtv@…

Hello Daniel,

Attached I have put the channels.conf, and a logfile of myth-setup where I try to import only 1 channel. I have chosen a channel that works, As sanity check I have tested it before and after importing this channel in MythTV.

BTW: Where can I find the option to decrease the time from 40 seconds to shorter?
I have no rotor anywhere, I only have switches and a WaveFrontier? T90 with room for 16 LNB's... So, a few seconds is more than enough for me...

Remy

Changed 7 years ago by anonymous

Changed 7 years ago by anonymous

Changed 7 years ago by mythtv@…

comment:5 Changed 7 years ago by janne

  • Description modified (diff)
  • Milestone changed from unknown to 0.21
  • Owner changed from danielk to janne

comment:6 Changed 7 years ago by janne

  • Resolution set to fixed
  • Status changed from new to closed

(In [13289]) Fixes #3011. Open DVB frontend read only to get frontend info

comment:7 Changed 7 years ago by janne

(In [13288]) Refs #3011

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.