Opened 13 years ago

Closed 13 years ago

#3013 closed defect (duplicate)

MythMusic segfault with certain files in playlist

Reported by: baard.sorngard@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythmusic Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If certain music files are added to the playlist in MythMusic, it causes MythTV to crash with a segmentation fault. I believe the problem may be that these files are corrupt, as they will not play correctly in Amarok (with xine) either (with ogg123, however, they do). Removing these files from the playlist solve the problem, but it would have been nice with an error message or something instead.

The music files I've tried are Oggs ripped from GTA San Andreas; however, these files are probably copyrighted, so I can't post them here. It is possible to extract these files from the original PC game with an extractor though, if anyone wants to try them.

The crash seems to occur only when you have used MythMusic once already that session.

Attachments (1)

gdb.txt (42.4 KB) - added by baard.sorngard@… 13 years ago.
backtrace

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by baard.sorngard@…

Attachment: gdb.txt added

backtrace

comment:1 Changed 13 years ago by myth@…

I've started looking at this; the backtrace contains two sigsegvs, the first looks like it's crashing in LibMad? (which could be related to a corrupt file), but the second trace looks like it's the thread-unsafe behaviour or MythObservable?, see ticket#2557.

comment:2 Changed 13 years ago by myth@…

Strike that comment, the first crash is also related to the event processing, it's thread 5865, not 6073, that's sigsegving.

comment:3 Changed 13 years ago by jlenk

I also was having trouble with crashes and did not know why. So after reading this bug I deleted all my Oggs and ripped them as MP3s and have not had a crash since. That was 48 hours ago and still playing with many start/stops of mythmusic. These Oggs were ripped with Mythmusic and played fine the first time mythmusic was used. The crash only would occur sometimes after play was started the second time.

comment:4 Changed 13 years ago by stuartm

Resolution: duplicate
Status: newclosed

This seems to be a duplicate of #2557

Note: See TracTickets for help on using tickets.