Opened 13 years ago

Closed 12 years ago

#3035 closed defect (duplicate)

1080i source material playback results in solid blue video with Via-XvMC

Reported by: midl_man@… Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords: 1080i via xvmc blue
Cc: Ticket locked: no

Description

FC6 on a Via EPIA-SP13000 (CN400 chipset). 1080i source material from a recorded ATSC broadcast plays back perfectly using Xine though curiously I must use the "xxmc" (nVidia XvMC) plugin as opposed to "xvmc" as the later doesn't play smooth while the former does. This demonstrates that the HW is capable of HD decode (and that for some reason it likes to be treated like nVidia HW -- at least by Xine).

With the same source material and a current 0.20-fixes snapshot compiled with xvmc and xvmc-pro, audio plays fine but the video is displayed as solid blue when using Via-XvMC. Out of curiosity I tried playing back with normal XvMC and the same source decodes/displays properly rather than displaying solid blue but it plays in short bursts.

Other source material such as 720p and DVD decodes properly with Via-XvMC. Adjusting playback properties such as bob/no deinterlacing has no visual effect on the 1080i results.

Attachments (1)

mythtv.diff (1015 bytes) - added by teague@… 13 years ago.
1080i Blue XvMC-VLD fix

Download all attachments as: .zip

Change History (8)

comment:1 Changed 13 years ago by midl_man@…

Keywords: 1080i via xvmc blue added

The same problem occurs when using minimyth (linpvr.org) on this hardware so it's not a FC6 specific issue either.

If it would help, I can get provide a small 1080i source clip (although even a short 5 second clip will be about 10MB).

Changed 13 years ago by teague@…

Attachment: mythtv.diff added

1080i Blue XvMC-VLD fix

comment:2 Changed 13 years ago by teague@…

The issue is not in the display of 1080i material, it's in the VLD decoding of the stream. The Epia SP (and newer boards) can decode the stream, boards don't have enough shared video memory (even at 64 Mb, the maximum setting) to allocate 16 decoding buffers.

The above attachment fixes this particular problem by reducing that number to 14, which (to my eye) doesn't result in a noticable difference in playback quality. Unforunately, the Epia SPs are marginal for HD playback in other areas; I've got a few more fixes that help with stuttering issues that I will try to package up and post here later.

comment:3 Changed 13 years ago by danielk

Owner: changed from Isaac Richards to danielk
Version: 0.20head

Isn't this already fixed in mythtv-vid?

comment:4 Changed 13 years ago by midl_man@…

Well, the patch doesn't fix the problem *but* dropping the number further from 14 to 12 does. (I didn't try 13.) FYI, it works at 10 too and to be honest, with about a 10 minute workout I couldn't see any difference between 10 and 12.

This doesn't seem like quite the right thing to do from a general purpose perspective but it does make 1080i decode work on the CN400 chipset for now. THANKS! I'll use it for now but be available to test future proposed patches.

comment:5 Changed 13 years ago by teague@…

Good to know. I'm using a recent SVN pull of OpenChrome? which, IIRC, has better memory management. I've also got the "DisableVQ" option disabled in my xorg.conf, which saves a bit more. I've tested a number of different values, and having more decoding buffers definitely boosts performance, especially for 720p content.

comment:6 Changed 13 years ago by anonymous

Version: head0.20

comment:7 Changed 12 years ago by danielk

Resolution: duplicate
Status: newclosed

Duplicate of #1842.

Note: See TracTickets for help on using tickets.