Opened 13 years ago

Closed 13 years ago

#3084 closed defect (duplicate)

partial lock only one some channels, most ok

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Since upgrading to svn latest and greatest I have noticed that I have lost the ability to view and record some DVB channels. As far as I can tell only 2 are affected, Film Four and ftn (UK). The problem is that I only get a partial lock on those channels. I can change to other channels ok or escape out, but the partial lock status never changes on those channels.

I have re-verified this with the latest as of today:

Library API version: 0.20.20070124-1 Source code version: 12786M

(only modification is #3046 patch applied).

I have also verified that it is not occuring using the following version (release-0-20-fixes):

Library API version: 0.20.20060828-3 Source code version: 12786

While I tested the above, I also noted that I was able to get a lock with trunk after my test on 0.02 fixes, but after changing channels and back again, I now get the partial lock only again.

The log entries I get is:

backend:

0: start_time: 2569.775 duration: 8590.014 1: start_time: 2569.858 duration: 8589.931 2: start_time: 2569.775 duration: 0.052 3: start_time: 2569.775 duration: 8590.014 4: start_time: 2569.775 duration: 8590.014 5: start_time: 2569.775 duration: 8590.014 6: start_time: 2569.775 duration: 8590.014 stream: start_time: 28553.058 duration: 95444.598 bitrate=0 kb/s 2007-02-13 00:01:42.624 AFD: Opened codec 0x8558770, id(MPEG2VIDEO) type(Video) 2007-02-13 00:01:42.624 AFD: Opened codec 0x8558d80, id(MP3) type(Audio) 2007-02-13 00:01:42.624 AFD: Opened codec 0x855a8a0, id(DVB_SUBTITLE) type(Subtitle) [mpegts @ 0xb75526b0]Parser not found for Codec Id: 94212 ! [mpegts @ 0xb75526b0]Parser not found for Codec Id: 94212 ! [mpeg2video @ 0xb745bdc8]00 motion_type at 4 22 [mpeg2video @ 0xb745bdc8]00 motion_type at 2 23 [mpeg2video @ 0xb745bdc8]00 motion_type at 9 24 [mpeg2video @ 0xb745bdc8]invalid mb type in P Frame at 3 25 [mpeg2video @ 0xb745bdc8]00 motion_type at 8 26 [mpeg2video @ 0xb745bdc8]00 motion_type at 12 27 [mpeg2video @ 0xb745bdc8]00 motion_type at 5 28 [mpeg2video @ 0xb745bdc8]00 motion_type at 5 29 [mpeg2video @ 0xb745bdc8]ac-tex damaged at 16 30 [mpeg2video @ 0xb745bdc8]ac-tex damaged at 1 31 [mpeg2video @ 0xb745bdc8]ac-tex damaged at 3 32 [mpeg2video @ 0xb745bdc8]00 motion_type at 4 33 [mpeg2video @ 0xb745bdc8]00 motion_type at 21 34 [mpeg2video @ 0xb745bdc8]00 motion_type at 4 35

Frontend:

[mpegts @ 0xb75e06b0]Parser not found for Codec Id: 94212 ! [mpegts @ 0xb75e06b0]Parser not found for Codec Id: 94212 ! [mpegts @ 0xb75e06b0]Parser not found for Codec Id: 94212 ! 2007-02-13 00:01:26.970 NVP: prebuffering pause 2007-02-13 00:01:27.569 XMLParse::LoadTheme? using /usr/local/share/mythtv/themes/G.A.N.T./ui.xml 2007-02-13 00:01:29.274 NVP: prebuffering pause 2007-02-13 00:01:32.676 NVP: prebuffering pause 2007-02-13 00:01:33.438 NVP: prebuffering pause 2007-02-13 00:01:41.978 NVP: prebuffering pause

Change History (3)

comment:1 Changed 13 years ago by mythtv@…

I too was having a similar problem until about 15 minutes ago when I discovered changeset #12619. Since around the time this changeset was committed (approx. 3 weeks) I have been experiencing many partial locks which just stay that way indefinitely.

About half of my DVB channels (mostly SD, I don't remember seeing it happen on HD channels) do not tune about 50% of the time.

The signal monitor in the OSD reports 'LMs', so I figured it's something to do with SDT parsing?

Anyway, I found changeset 12619 this evening and have manually enabled quicktune on my DVB cardinput and now I can tune all channels 100% successfully again and my channel change time is quite a bit quicker than when it was working previously.

Did #12619 perhaps break something else that wasn't caught in the #12626 fix?

Johan

comment:2 Changed 13 years ago by anonymous

Johan, tried your recommendation (turning on quick tune) and it works (but is it reliable?)! As you say, there must be something broken about that changeset.

comment:3 Changed 13 years ago by danielk

Resolution: duplicate
Status: newclosed

Duplicate of #3031.

Note: See TracTickets for help on using tickets.