Opened 13 years ago

Closed 13 years ago

#3087 closed defect (worksforme)

Unable to delete schedules within frontend

Reported by: mattsch@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

As I was setting up recording schedules yesterday, I messed up a recording schedule. I wanted to go delete it but when I went into upcoming recordings and pressed the "D" key or "Delete" key, it doesn't do anything. The only way I was able to delete the schedule was to delete it from the records table through mysql.

Change History (7)

comment:1 Changed 13 years ago by mattsch@…

s/records/record

comment:2 Changed 13 years ago by kkuphal

Resolution: worksforme
Status: newclosed

Firstly, this is a -users list question. Secondly, you can remove recording schedules by editing the schedule and setting it to "Do not record"

comment:3 Changed 13 years ago by mattsch@…

Resolution: worksforme
Status: closedreopened

Setting it to do not record does not remove the schedule. It is still there unless at some point there is garbage collection? If it is only removed by gc, then I think it should be changed to immediate.

comment:4 Changed 13 years ago by kkuphal

Resolution: worksforme
Status: reopenedclosed

Trac is not a mailing list. Please take the discussion of your issues to the -users mailing list. As indicated, this works for me and is a fairly basic function so unless you can provide reproducible steps, please do not reopen.

comment:5 Changed 13 years ago by mattsch@…

Resolution: worksforme
Status: closedreopened

I don't think I was specific enough. If a recording was set to never record after it was set up to recur weekly in the same timeslot, it does not delete when the time passes for the current program set.

comment:6 Changed 13 years ago by mattsch@…

It looks like it is expiring now for the recurring time slots. I think this behavior is wrong. Without being able to delete the recording immediately, it clutters the recording screen until it expires. I know I can delete this in mysql but it would be nice if you had a selection to delete instead of/in addition to Don't Record.

comment:7 Changed 13 years ago by stuartm

Resolution: worksforme
Status: reopenedclosed

I can't reproduce this. 'D' on the upcoming recordings page deletes the schedule. Please check if this still doesn't work for you with the latest development version of mythtv.

Note: See TracTickets for help on using tickets.