Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#3099 closed defect (fixed)

Empty Watch Recordings screen with no way out

Reported by: ylee@… Owned by: cpinkham
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords: empty watch recordings stuck exit
Cc: Ticket locked: no

Description

I use 0.20-fixes (ATrpms 151), r12674. I can get mythfrontend into a strange situation by doing the following:

  • Go to Watch Recordings.
  • In the list of Program Groups, pick one with a password.
  • At the password prompt, hit the Escape key to abort the entry.

This results in an empty Watch Recordings screen with the "Sorry, No Recordings Available" message. There is no escape from here as far as I know; neither the Escape nor any jumppoint key works. I have to kill and restart mythfrontend.

See the thread beginning at http://www.gossamer-threads.com/lists/mythtv/users/253254#253254 for more information.

Change History (16)

comment:1 Changed 13 years ago by cpinkham

Owner: changed from Isaac Richards to cpinkham

comment:2 Changed 13 years ago by cpinkham

Resolution: fixed
Status: newclosed

(In [13026]) When the user hits ESCape on the Watch Recordings Screen's Recording Group password prompt, return them to where they were at rather than presenting them with a blank recordings list. If you were on the main menu and just came into the Watch Recordings screen and have QueryInitialFilter? turned on then you will be returned to the menu. If you were already in the Watch Recordings screen, you will be left in the previously shown Recording Group.

Closes #3099.

comment:3 Changed 13 years ago by cpinkham

(In [13027]) Carry over [13026] from trunk.

When the user hits ESCape on the Watch Recordings Screen's Recording Group password prompt, return them to where they were at rather than presenting them with a blank recordings list. If you were on the main menu and just came into the Watch Recordings screen and have QueryInitialFilter? turned on then you will be returned to the menu. If you were already in the Watch Recordings screen, you will be left in the previously shown Recording Group.

References #3099.

comment:4 Changed 13 years ago by ylee@…

Keywords: empty watch recordings stuck exit added
Resolution: fixed
Status: closedreopened
Summary: Hitting Escape key at Recording Groups password prompt = Empty Watch Recordings screen with no way outEmpty Watch Recordings screen with no way out

Reopening this ticket and changed Subject line because I found two more ways to trigger the above bug:

  • I have recordings from a prior database I imported into the current one (which I've been using for 13 months) and so aren't assigned to any categories. Thus, in the Select Group Filter popup box, I have an entry under "Categories" that appears as the following:
      [26 items]
    
    i.e., a null category. Selecting this entry triggers the bug.
  • Some other entries under "Categories" also trigger the bug. I think categories that contain programs that are members of a Recording Group other than the one being viewed at the moment (my default Recording Group is Default, not All Programs) are the ones this bug affects.

I am still using 0.20-fixes ATrpms, but now r13045, so I am running the patch (much appreciated) that fixed the way to trigger the bug that originally prompted this ticket.

comment:5 Changed 13 years ago by cpinkham

Resolution: fixed
Status: reopenedclosed

(In [13094]) Make recordings with a blank category field show up as "Unknown" in the Recording Group/Category? chooser popup.

Seems to fix the first issue in #3099, I'm unable to replicate the second, so it is possibly fixed also.

Closes #3099.

comment:6 Changed 13 years ago by cpinkham

(In [13095]) Carry over [13094] from trunk.

Make recordings with a blank category field show up as "Unknown" in the Recording Group/Category? chooser popup.

Seems to fix the first issue in #3099, I'm unable to replicate the second, so it is possibly fixed also.

References #3099.

comment:7 in reply to:  6 ; Changed 13 years ago by anonymous

Replying to cpinkham:

(In [13095]) Carry over [13094] from trunk.

Make recordings with a blank category field show up as "Unknown" in the Recording Group/Category? chooser popup.

Seems to fix the first issue in #3099, I'm unable to replicate the second, so it is possibly fixed also.

References #3099.

I'm pleased to report that the blank category-field issue is indeed fixed nicely. However, the second issue I reported in my previous message is still there, alas. Here's how I trigger it:

  • Assign a password to a Recording Group.
  • Assign programs in a certain category to that group. (Possibly *all* programs in that category.)
  • From another Recording Group, choose that category.
  • Enter the password.
  • Bug triggers.

comment:8 in reply to:  7 ; Changed 13 years ago by ylee@…

Replying to anonymous (actually me):

  • Assign programs in a certain category to that group. (Possibly *all* programs in that category.)

After further experimentation, the bug indeed does require all programs in said category to be in that Recording Group. A specific example with real categories:

  • I assign the only Aviation-category recording, Warplane, to the Other Recording Group, which has a password.
  • While viewing the Default Recording Group, I bring up

Recording List Menu|Change Group Filter|Aviation [1 item].

  • Bug triggers.

comment:9 in reply to:  8 ; Changed 13 years ago by anonymous

Replying to ylee@pobox.com:

  • I assign the only Aviation-category recording, Warplane, to the Other Recording Group, which has a password.

Sorry. Forgot to mention that in my testing, if Other does not have an assigned password, the bug does not trigger.

comment:10 in reply to:  9 Changed 13 years ago by ylee@…

Resolution: fixed
Status: closedreopened

Oops; forgot to reopen ticket when adding the above comments.

comment:11 Changed 13 years ago by anonymous

Possibly related.

If all recordings in a group are moved to a new group, the "Sorry, No Recordings Available" will appear. There is no escape from this except to kill the frontend just like in the first report.

Recordings were moved one at a time with Menu | Change Group Filter | select new group. The source group did have a password.

Using latest myth from ATrpms mythtv-0.20-154 r13045

comment:12 in reply to:  3 Changed 13 years ago by anonymous

Replying to cpinkham:

(In [13027]) Carry over [13026] from trunk.

When the user hits ESCape on the Watch Recordings Screen's Recording Group password prompt, return them to where they were at rather than presenting them with a blank recordings list . . . If you were already in the Watch Recordings screen, you will be left in the previously shown Recording Group.

I found another, minor, issue with the fix for the above (in ATrpms 0.20-155 r13228, at least). Here's how to trigger it:

  • Make sure TV Settings|Playback|View Recordings (Recording Groups)|Show filter name instead of "All Programs" is checked on.
  • From any group filter (All Programs or any one under "Groups") in Watch Recordings, go to one requiring a password.
  • Push ESC at the password prompt.
  • The above fix properly brings the user back to the original Watch Recordings screen, but with a subtle difference: The default heading on the left-hand side (the heading that lists all programs) that's labeled with the current group filter name has now changed to the name of the filter that the user did not succeed in changing to. Exiting and reentering Watch Recordings, or switching to another display filter, fixes this.

comment:13 Changed 12 years ago by cpinkham

I'm still unable to reproduce the "stuck in Watch Recordings" error. I have reproduced the examples given and was just presented with the "no recordings available" screen and I could easily ESCape out of that or change groups. I do have a fix for the "show filter name instead of all programs" bug mentioned in comment 12. I am about to commit that.

comment:14 Changed 12 years ago by cpinkham

Resolution: fixed
Status: reopenedclosed

(In [13900]) Fix an issue of the wrong filter name appearing in the title section when the user aborted changing filters when trying to change to a Recording Group that had a password.

Also don't include recordings that are being deleted in the category counts on the filter change popup.

Closes #3099.

comment:15 Changed 12 years ago by cpinkham

(In [13901]) Carries over [13900] from trunk.

Fix an issue of the wrong filter name appearing in the title section when the user aborted changing filters when trying to change to a Recording Group that had a password.

Also don't include recordings that are being deleted in the category counts on the filter change popup.

References #3099.

comment:16 Changed 12 years ago by cpinkham

(In [15392]) Fix an issue with the Watch Recordings screen hanging if you have preview video turned on and remove the last entry from the current view and the try to exit the screen.

Closes #4421 using patch by Ron Frazier. References #3099.

Note: See TracTickets for help on using tickets.