Opened 13 years ago

Closed 13 years ago

#3108 closed defect (wontfix)

Strange FFMPEG warning when transcoding starts

Reported by: greg Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I rarely do any sort of transcoding with the internal transcoder, but today when I kicked one off I saw the following warning. Per our IRC convo I'm putting it into a ticket.


2007-02-19 11:15:14.363 Transcoding from /data/mythtv/1009_20070207210000.mpg to /data/mythtv/1009_20070207210000.mpg.tmp 2007-02-19 11:15:14.411 Connecting to backend server: 192.168.0.10:6543 (try 1 of 5) 2007-02-19 11:15:14.413 Using protocol version 32 2007-02-19 11:15:14.414 MainServer::HandleAnnounce? Monitor 2007-02-19 11:15:14.414 adding: woop as a client (events: 0) 2007-02-19 11:15:14.415 MainServer::HandleAnnounce? Monitor 2007-02-19 11:15:14.415 adding: woop as a client (events: 1) Compiler did not align stack variables. Libavcodec has been miscompiled and may be very slow or crash. This is not a bug in libavcodec, but in the compiler. Do not report crashes to FFmpeg developers. 0: start_time: 0.036 duration: 8589.932 1: start_time: 0.030 duration: -9223372036854.775 stream: start_time: 0.334 duration: 95443.751 bitrate=0 kb/s 2007-02-19 11:15:14.484 AFD: Opened codec 0x81924b0, id(MPEG2VIDEO) type(Video) 2007-02-19 11:15:14.487 AFD: Opened codec 0x8192900, id(MP2) type(Audio) 2007-02-19 11:15:15.856 New DB connection, total: 3 2007-02-19 11:15:15.858 Connected to database 'mythconverg' at host: localhost 2007-02-19 11:15:16.809 Copying Audio while transcoding Video


The box is an Athlon XP2500+, 512meg of ram, running Slackware 10.1.0, and gcc 3.3.4 with and svn trunk checkout of 12786.

Recording was made on a PVR250 and transcoding to Mpeg4

Configure line is : ./configure --enable-xvmc --enable-opengl-vsync --enable-dvb --disable-dbox2 --arch=athlon-xp --with-bindings=perl

Change History (2)

comment:1 Changed 13 years ago by Janne Grunau

Owner: changed from Isaac Richards to Janne Grunau
Version: 0.20head

comment:2 Changed 13 years ago by Janne Grunau

Resolution: wontfix
Status: newclosed

It's a gcc bug, ffmpeg devs suggest updating gcc to gcc 4 or later

Note: See TracTickets for help on using tickets.