Opened 13 years ago

Closed 12 years ago

#3109 closed defect (fixed)

no full-screen with beryl

Reported by: ikke@… Owned by: stuartm
Priority: trivial Milestone: 0.22
Component: mythtv Version: 0.20
Severity: low Keywords:
Cc: Ticket locked: no

Description

Hi,

this is a minor annoyance. Mythtv is full-screen always but while using beryl window manager under gnome. It has always been the problem there. I have not set up separate resolutions for video and GUI, nor do I run it in windowed mode. Resolution is set to monitor max 1440x900. But still gnome-panel is always visible on screen and mythtv is little bit squeezed between top and bottom gnome-panel. Other applications (e.g. firefox) gets full-screen just fine, but mythtv doesn't. So I assume it's mythtv's misfeature.

In other words, it looks like mythtv would put the image on some (wrong?) layer which then gets grabbed by beryl and it squeezes the layer in between the gnome-panels. Not that I know of X11 and if it has layers or not, but since beryl is 3d it might as well have...

I watch mythtv via nvidia 6200 run with 9746 binary drivers, on 19" 1440x900 resolution on up to date ubuntu 6.10 gnome with beryl. Same problem has existed with several versions of beryl. Mythtv version doesn't matter in this case, but I use trunk.

I would have a screen-shot (37 kB), just don't know where to upload it... if anyone is interested I'm glad to mail it to you.

Attachments (1)

under.png (252.1 KB) - added by anonymous 13 years ago.
MythTV underneath gnome-panel while in beryl

Download all attachments as: .zip

Change History (12)

comment:1 Changed 13 years ago by anonymous

I'm seeing this also. Attaching screenshot to emphasize. It appears as though Myth is just underneath the gnome-panels, not squished between them.

This only happens in beryl/compiz, Switching back to Metacity everything is kosher.

Changed 13 years ago by anonymous

Attachment: under.png added

MythTV underneath gnome-panel while in beryl

comment:2 Changed 13 years ago by halovanic@…

The problem isn't specific to GNOME and its panels either, it happens here with KDE's panels while running Beryl

comment:3 Changed 13 years ago by smith.chuck@…

Confirmed here.

Also, I'd note that even when selecting things like "On Top" for the MythTV window, it's still not true full-screen (i.e., panel on top still shows).

When running in full screen and hiding the panel on top, there is no video behind it at all (can be demonstrated by using autohide or hide buttons on the panel). This suggests to me that MythTV gets a bad value for its window dimensions when using Beryl (H = Screen Resolution - Top Panel Height x W = Screen Resolution), possibly?

comment:4 Changed 13 years ago by iscy@…

I'm using beryl head & myth head and I'm not seeing this.

Configuration issue perhaps?

comment:5 Changed 12 years ago by ikke@…

Hei,

I thought to update the description. System is now upgraded to Ubuntu Feisty, still running quite up-to-date trunk mythtv. I also changed the settings not to have fixed resolution (1440x900) but to let mythtv to calculate the size by itself. The same thing still happens. I noticed by accident that mythtv screen is really a window because I can move it around by pressing alt and dragging it around with mouse.

Any normal window that is in full-screen mode can not be dragged around. So some mythtv window attribute is wrong, it is not a true full-screen window. It's more like a maximized window instead.

comment:6 Changed 12 years ago by anonymous

I can confirm mythfrontend does not run as fullscreen window, it is always a maximized window without border. There is a configuration option "MythTV im Fenster starten" ("start mythtv in a window" or something like that), which has no effect on said problem.

comment:7 Changed 12 years ago by stuartm

Owner: changed from Isaac Richards to stuartm
Severity: mediumlow
Status: newassigned

The way mythtv behaves is no different to many applications and is perfectly correct. Until very recently X didn't really support the concept of "fullscreen". The only way to create a fullscreen effect was to use a window whose dimensions were set to that of the screen and remove the border.

X, as of recent versions, now has a proper fullscreen property but it's not supported by QT3. We may be able to set the property directly but until then, there is a workaround within Compiz itself.

The "Workaround" plugin, offers the following setting "Legacy Fullscreen Support". Enable that and you should be able to use mythfrontend in fullscreen mode with Compiz.

See: http://miffteevee.co.uk/imagebin/compiz_legacy_fullscreen.png

comment:8 Changed 12 years ago by stuartm

Milestone: unknown0.22
Priority: minortrivial

comment:9 Changed 12 years ago by stuartm

Resolution: invalid
Status: acceptedclosed

comment:10 Changed 12 years ago by stuartm

Resolution: invalid
Status: closednew

comment:11 Changed 12 years ago by stuartm

Resolution: fixed
Status: newclosed

(In [16646]) Update the window flags and attributes to their QT4 equivalents. Fixes #3109

Note: See TracTickets for help on using tickets.