Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#3133 closed defect (worksforme)

Schema Upgrade fails for 1180 -> 1181

Reported by: jonathanjstevens@… Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords: schema upgrade
Cc: Ticket locked: no

Description

After SVN upgrade the myth setup (and also backend) fail to start as below. I have seen something similar on SQL bug reports, but have no idea how to work around or fix. I have tried restoring db, all checks out ok.

Linux mythtv.storm.to 2.6.19-1.2288.fc5 #1 Sat Feb 10 14:52:17 EST 2007 i686 i686 i386 GNU/Linux

mysql Ver 14.12 Distrib 5.0.27, for redhat-linux-gnu (i686) using readline 5.0

Output of mythtv-setup will be attached.

Change History (2)

comment:1 Changed 13 years ago by cpinkham

Resolution: worksforme
Status: newclosed

No log was attached as noted by the submitter, and the only thing that 1081 did was create a few indexes, so something doesn't seem right with this ticket. My dev box has done this upgrade multiple times without issue. Closing ticket.

comment:2 Changed 13 years ago by sphery <mtdean@…>

Log was included at http://www.gossamer-threads.com/lists/mythtv/dev/255005#255005 . However, after discussion with the OP, I'm pretty certain the problem was due to bad data caused by a corrupted table. Although he had repaired the table before the upgrade, his recordedmarkup table was left with some corrupt data--i.e. it had frame numbers like -4615295431613890272 and 628392387440795712 .

Note: See TracTickets for help on using tickets.