Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#3140 closed defect (worksforme)

MythMusic segfault when switching visualizers

Reported by: xris Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythmusic Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When switching away from the vertical-line style visualizer in fullscreen mode, mythmusic segfaults.

Attachments (1)

music_backtrace.txt (41.0 KB) - added by xris 13 years ago.

Download all attachments as: .zip

Change History (7)

Changed 13 years ago by xris

Attachment: music_backtrace.txt added

comment:1 Changed 12 years ago by paulh

Resolution: worksforme
Status: newclosed

Chris, I've done a lot of switching visualizers over the last few days and haven't been able to reproduce this one. Also there's been a few changes to the visualizer code since you submitted this ticket. Can you still reproduce it with current svn?

comment:2 Changed 12 years ago by otto at kolsi dot fi

Just upgraded and played a bit with new visualizers. Very nice, thanks Paul for all your work!

I tried all the visualizers and just quickly changed them to see the new ones. While doing that, I got frontend to crash couple of times with lots of following lines in logs:

libvisual CRITICAL: mythmusic: visual_buffer_get_data(): assertion `buffer != NULL' failed


/usr/local/bin/mythfrontend: symbol lookup error: /usr/lib/libvisual-0.4/actor/actor_nastyfft.so: undefined symbol: visual_mem_malloc0


libvisual CRITICAL: mythmusic: mfl_DestroyFont(): assertion `f != NULL' failed


(process:8306): GdkPixbuf-CRITICAL **: gdk_pixbuf_scale_simple: assertion `src != NULL' failed
libvisual CRITICAL: mythmusic: update_scaled_pixbuf(): assertion `priv->scaled != NULL' failed


libvisual CRITICAL: mythmusic: visual_buffer_get_allocated(): assertion `buffer != NULL' failed
libvisual CRITICAL: mythmusic: visual_video_set_buffer(): Trying to set a screen buffer on a VisVideo structure which points to an allocated screen buffer
libvisual CRITICAL: mythmusic: load_new_file(): assertion `priv->pixbuf != NULL' failed

This is a PIV Celeron machine with FC5 and libvisual installed as a rpm package. Are these problems only in libvisual code.. would there be anything interesting in frontend backtrace?

comment:3 Changed 12 years ago by xris

I can't seem to test this. I'm not getting any visualizers as of a recompile last night.

comment:4 in reply to:  2 ; Changed 12 years ago by paulh

Replying to otto at kolsi dot fi:

Just upgraded and played a bit with new visualizers. Very nice, thanks Paul for all your work!

I tried all the visualizers and just quickly changed them to see the new ones. While doing that, I got frontend to crash couple of times with lots of following lines in logs:

libvisual CRITICAL: mythmusic: visual_buffer_get_data(): assertion `buffer != NULL' failed
libvisual CRITICAL: mythmusic: mfl_DestroyFont(): assertion `f != NULL' failed

<snip>

Looks like all of these errors are from libvisual.

For me all the visualizers work fine except two gstreamer and gdkpixbuf. I wasn't to bothered about that because they don't work in Amarok either :-)

Do they all work OK in another player that supports libvisual like Amarok or xmms?

comment:5 in reply to:  3 Changed 12 years ago by paulh

Replying to xris:

I can't seem to test this. I'm not getting any visualizers as of a recompile last night.

I only commited the changes to the visualizer stuff this morning (11.26 UK time) so its unlikely you have those changes already.

comment:6 in reply to:  4 Changed 12 years ago by otto at kolsi dot fi

Replying to paulh:

For me all the visualizers work fine except two gstreamer and gdkpixbuf. I wasn't to bothered about that because they don't work in Amarok either :-)

Do they all work OK in another player that supports libvisual like Amarok or xmms?

I haven't tested these with other players. I found out that at least "nastyfft" and "jakdaw" keep crashing on my machine. But like you said, its most probably in libvisual code. And I'm happy with several new good looking and working visualizations :)

Note: See TracTickets for help on using tickets.