Opened 12 years ago

Closed 12 years ago

#3177 closed defect (worksforme)

nvram-wakeup, mythshutdown, mythwelcome and time_t

Reported by: anonymous Owned by: paulh
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords: mythwelcome, time_t, mythshutdown
Cc: Ticket locked: no

Description

I was using the shutdown wakeup features of mythwelcome/shutdown for some time without issue. When I upgraded to head (today) I ran across some issues involving the time format being passed between the two.

Here are the errors that get produced:

QTime::fromString: Parameter out of range QDate::setYMD: Invalid date 1173-11-60 nvram-wakeup: RTC is not synchronously with system time! nvram-wakeup: RTC isn't running in localtime nor in UTC/GMT time!

the nvram-wakeup issues can be dealt with on my own because they are just system settings (but they were never present before so if you can give me a hint to why they appeared it would be great).

I'm using a standard nvram-wakeup -s $time function to wake up, and time_t as the argument in mythwelcome.

Change History (3)

comment:1 Changed 12 years ago by devel@…

There were some changes to mythwelcome to make the nvram-wakeup command configurable rather than hard-coded. Can you provide a log with -v all parameter set. Also, are these errors occurring with mythwelcome or mythshutdown? What are the specific actions you are taking when this is occurring?

comment:2 Changed 12 years ago by paulh

Owner: changed from Isaac Richards to paulh

comment:3 Changed 12 years ago by paulh

Resolution: worksforme
Status: newclosed

You can probably fix the

nvram-wakeup: RTC is not synchronously with system time! 
nvram-wakeup: RTC isn't running in localtime nor in UTC/GMT time!

messages by doing something like this

hwclock --systohc

to make sure the RTC is the same as the system time.

As for the other error it's difficult to know what's the problem without a log to put the error into context. If you can still reproduce the problem after double checking all the shutdown settings are correct and updating to latest svn head then and add

-v all

to the 'Set wakeuptime command' and 'Server Halt command' settings so the 'Server Halt' command would now look something like this

mythshutdown -v all --shutdown

and attach the resulting backend log.

Reopen this ticket when the log is available.

Note: See TracTickets for help on using tickets.