Opened 13 years ago

Closed 10 years ago

#3204 closed defect (worksforme)

Confusing display of rsOtherShowing/rsWillRecord status in EPG

Reported by: Nick Morrott <knowledgejunkie@…> Owned by: Shane Shrybman
Priority: minor Milestone: 0.22
Component: mythtv Version: head
Severity: medium Keywords: epg other showing will record
Cc: Ticket locked: no

Description

My EPG lineup consists of many channels available from 2 video sources. There are many instances where the same station is avaiable on both sources, so the channels are configured will same callsign/channum. In MythWeb and the MythTV EPG, only one of these channels is shown, as is the expected behaviour.

However, in the MythTV EPG there is inconsistency when selecting scheduled recordings in the EPG, as some will show "Will Record", others will show "Other Showing". I haven't determined a logic to which shows are flagged as which, apart from the order in which the EPG is filled with channel data. I have also read changesets [11796] and [12463].

When using a configuration where channels have been configured with the same callsign/channum to reflect the same underlying station and to display only once in the MythTV/MythWeb EPGs, shouldn't all programs scheduled to record show a status of 'Will Record'? I can see 'Other Showing' being very confusing when the 'other showing' is not displayed.

The same behaviour also occurs when listing matches for rules/titles.

Change History (4)

comment:1 Changed 13 years ago by Nick Morrott <knowledgejunkie@…>

Probing further into where confusion is seen, I have observed the following GUI elements where programs which *will* record can be listed as 'Other Showing' and consequently are *not* highlighted:

Programme Listing (Title Search)

Rule Search

Power Search

Programme Finder

Film Search

Category Search

Time Search

New Title Search

GUI elements where 'Will Record' programs seem to be correctly and consistently highlighted include:

Upcoming Recordings

Channel Search

Nick

comment:2 Changed 11 years ago by Shane Shrybman

Milestone: unknown0.22
Owner: changed from Isaac Richards to Shane Shrybman
Status: newassigned

Hi Nick,

Heh, a little tardy getting to this ticket. ;)

Is this still an issue with current trunk? I just did a quick test and it seems to report Other Showing and Will Record correctly on a few of the screens you mentioned were problematic.

comment:3 Changed 11 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

Let me check and get back to you. I'm currently running 0.21-fixes on my production systems so cannot easily vouch for trunk, although I was running trunk when I posted the initial report over two years ago.

As outlined above, there were several stations available simultaneously from multiple (in my case 2) video sources. I'm thinking that the behaviour seen was due to the fact that each of those video sources used the same listings data, but that the seemingly random order in which dialogs/screens were filled dictated whether or not the recording details displayed was from the video source to be used for the recording or not. In the former case, the Will Record info was displayed, in the latter case the 'Other Showing' info was displayed.

A question for the devs - what logic is used when filling the different dialogs (listed above) when the listings data (and scheduling details) is available for a particular station configured on multiple sources?

comment:4 Changed 10 years ago by Shane Shrybman

Resolution: worksforme
Status: assignedclosed

Too long without verification that this is a problem with a current version.

Note: See TracTickets for help on using tickets.