Opened 13 years ago

Closed 12 years ago

#3213 closed defect (worksforme)

Album art doesn't work with symbolic links to music dir

Reported by: anonymous Owned by: paulh
Priority: minor Milestone: 0.21
Component: mythmusic Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

After fix 13040 I can see the album art only from one album, all other albums are blank. Based on the attached log it seems that there's something wrong with music_directories.path (full log attached). Fix 13047 doesn't seem to fix this.

Non working album:

2007-03-15 22:02:16.224 MSqlQuery: SELECT CONCAT_WS('/', music_directories.path, music_albumart.filename) FROM music_albumart LEFT JOIN music_directories ON music_directories.directory_id=music_albumart.directory_id WHERE music_directories.path = 'ythtv/music/Audioslave/Audioslave';

Working album:

2007-03-15 22:02:24.224 MSqlQuery: SELECT CONCAT_WS('/', music_directories.path, music_albumart.filename) FROM music_albumart LEFT JOIN music_directories ON music_directories.directory_id=music_albumart.directory_id WHERE music_directories.path = 'Various_Artists/William_Shakespeare''s_Romeo_+_Juliet';

Attachments (2)

log.zip (52.5 KB) - added by t-p@… 13 years ago.
example.txt (1.1 KB) - added by t-p 12 years ago.
Example of the directory structure

Download all attachments as: .zip

Change History (8)

Changed 13 years ago by t-p@…

Attachment: log.zip added

comment:1 Changed 13 years ago by anonymous

Component: mythtvmythmusic

comment:2 Changed 13 years ago by stuartm

Milestone: unknown0.21
Owner: changed from Isaac Richards to stuartm
Severity: mediumlow
Summary: Album art in MythMusic doesn't workAlbum art doesn't work with symbolic links to music dir
Version: 0.20head

comment:3 Changed 12 years ago by paulh

Could you give an example of how the files are laid out so I can maybe try to reproduce this.

comment:4 in reply to:  3 Changed 12 years ago by anonymous

Replying to paulh:

Could you give an example of how the files are laid out so I can maybe try to reproduce this.

I managed to fix this bug by changing in MythMusic settings "Directory to hold music" from /music to /home/mythtv/music (/music was symbolic link to the same directory).

The structure in the music directory is artist/album/songs + folder_large.jpg containing the album art, see attached example.txt.

Changed 12 years ago by t-p

Attachment: example.txt added

Example of the directory structure

comment:5 Changed 12 years ago by stuartm

Owner: changed from stuartm to paulh
Status: newassigned

comment:6 Changed 12 years ago by paulh

Resolution: worksforme
Status: assignedclosed

Don't seem to be able to reproduce this one. Closing as works for me.

Note: See TracTickets for help on using tickets.