Opened 13 years ago

Closed 13 years ago

#3215 closed defect (duplicate)

upnp service announcing on wrong interface

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

My backend is also an router, therefore it has 2 interfaces (eth0 and eth1/ppp0), the backendserverip is set to match eth0, the internal interface. I was wondering why the backend log mentioned the upnp service, but i could not get any clent on the network to discover it. After some time some messages appereared in the log (logging with -v upnp)


2007-03-13 17:38:14.974 upnp:rootdevice 2007-03-13 17:38:14.974 * uuid:d1a5659e-6610-4c7c-b7ba-95981331ff94::upnp:rootdevice | 1903 | http://89.245.121.129:6544/getDeviceDesc 2007-03-13 17:38:14.978 urn:schemas-upnp-org:service:ConnectionManager:1 2007-03-13 17:38:14.979 * uuid:d1a5659e-6610-4c7c-b7ba-95981331ff94::urn:schemas-upnp-org:service:ConnectionManager:1 | 1905 | http://89.245.121.129:6544/getDeviceDesc 2007-03-13 17:38:14.981 urn:schemas-upnp-org:service:ContentDirectory:1 2007-03-13 17:38:14.981 * uuid:d1a5659e-6610-4c7c-b7ba-95981331ff94::urn:schemas-upnp-org:service:ContentDirectory:1 | 1905 | http://89.245.121.129:6544/getDeviceDesc


The ip was the one i got from my isp at that time, not my lan interface, so upnp is useless as it broadcasts into the void. myth was compiled from svn recently.

Change History (2)

comment:1 Changed 13 years ago by Janne Grunau

Version: 0.20head

comment:2 Changed 13 years ago by dblain

Resolution: duplicate
Status: newclosed

This is a duplicate of ticket #2467 and was fixed in revision 13208.

Re-open the ticket and supply the revision are you running if it is newer than 13208.

Note: See TracTickets for help on using tickets.