Opened 12 years ago

Closed 12 years ago

#3234 closed patch (fixed)

Allow mythplugins/mythbrowser to compile on gentoo with kde 3.5

Reported by: anonymous Owned by: paulh
Priority: minor Milestone: 0.21
Component: mythbrowser Version: 0.20
Severity: low Keywords: gentoo kde3.5
Cc: Ticket locked: no

Description

Mythbrowser will appropriately detect the kde libraries but will not compile. The following patch to the two .pro files for mythbrowser.pro and mythbookmarkmanager.pro allows it to compile.

Attachments (1)

gentoo-kde35-mythbrowser.patch (1.2 KB) - added by davideshay@… 12 years ago.

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by davideshay@…

comment:1 Changed 12 years ago by paulh

I thought this problem was already fixed.

I think that if you have the $KDEDIR variable set correctly for your system then the correct include and lib directories should be used.

comment:2 Changed 12 years ago by davideshay@…

Will see if that alone does it.

comment:3 Changed 12 years ago by stuartm

Milestone: unknown0.21
Resolution: invalid
Status: newclosed

comment:4 Changed 12 years ago by davideshay@…

Resolution: invalid
Status: closedreopened

Tried setting KDEDIR alone, still doesn't compile mythbrowser on gentoo. Also, KDEDIR as an environment variable is apparently deprecated. You can get the value by doing kde-config --prefix. We could avoid adding all various different values for different distros by using that command and storing it. I'll write up a patch for that, but only if it will get accepted, otherwise, I'll just keep applying this one locally.

comment:5 Changed 12 years ago by paulh

Owner: changed from Isaac Richards to paulh
Status: reopenednew

comment:6 Changed 12 years ago by paulh

Resolution: fixed
Status: newclosed

(In [13739]) Use 'kde-config' to find the KDE includes and libraries.

Tested on Gentoo x86_32 and Fedora Core 6 x86_64 both with KDE 3.5.

Closes #3234.

Note: See TracTickets for help on using tickets.