Opened 13 years ago

Closed 13 years ago

#3238 closed defect (fixed)

DVD subtitles if activated using the togglecc button may not work.

Reported by: stuartm Owned by: skamithi
Priority: minor Milestone: 0.21
Component: mythdvd Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

A regression sometime in the last 6 months (?) causes the DVD subtitles to be turned off after just one set is shown.

The -v playback log doesn't show anything useful - The first set is 'set visible' they expire correctly.

Attachments (1)

ticket_3238.2.diff (1.4 KB) - added by skamithi 13 years ago.
dvdringbuf->settrack tells dvd code not to read dvd for current subtitle track. move this code to nvp::enablecaptions and nvp::disablecaptions for more consistent results.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 13 years ago by stuartm

Owner: changed from Anduin Withers to skamithi

comment:2 Changed 13 years ago by skamithi

dvd subtitles work fine for me. i'm using the latest mythtv-vid. need more details: dvd used.. was subtitles turned on from the dvd menu ??

comment:3 Changed 13 years ago by stuartm

All DVDs I've tried - including Walk the Line, Gladiator and Garden State (Region 2 - PAL). The last two, at least, worked fine when I last tried them.

DVDs were turned on by hitting 'T' (or OSD menu).

comment:4 Changed 13 years ago by stuartm

Just tried turning them on at the DVD menu and they actually stay enabled.

comment:5 Changed 13 years ago by luitjens

I have seen this also. It seems to me that the problem is related to the subtitles being turned on and then immediately turned off. If i go through the menu to turn it on it stays on. This seems to happen regardless of dvd but is intermittent. It is possible that it is a lirc problem where it is reading repeats to fast or it could be a defect with mythtv.

comment:6 Changed 13 years ago by skamithi

Milestone: unknown0.21
Status: newassigned
Summary: DVD subtitles turned off after one line displayedDVD subtitles if activated using the togglecc button may not work.

Changed 13 years ago by skamithi

Attachment: ticket_3238.2.diff added

dvdringbuf->settrack tells dvd code not to read dvd for current subtitle track. move this code to nvp::enablecaptions and nvp::disablecaptions for more consistent results.

comment:7 Changed 13 years ago by skamithi

please test patch. resolves the toggleCC issue for me.

comment:8 Changed 13 years ago by anonymous

Patch works.

comment:9 Changed 13 years ago by skamithi

Resolution: fixed
Status: assignedclosed

(In [13098]) Closes #3238. internal dvd player: resolves the problem where activating dvd subtitles using the togglecc button may not work

Note: See TracTickets for help on using tickets.