Opened 13 years ago

Closed 13 years ago

#3239 closed defect (duplicate)

MythTV 0.20 SVN (Kubuntu Feisty) crashes when scanning Freeview Channels

Reported by: anonymous Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: mythtv Version: 0.20
Severity: high Keywords: scanning channels crash
Cc: Ticket locked: no

Description

Hi, I have MythTV 0.20 SVN on Kubuntu Feisty with nvidia-glx. I have installed all of the additional plugins in the repository.

I have a Nebula DigiTV card (Zarlink), Asus Nvidia Geforce 7600, and Athlon 64 X2 on Asus Nvidia Nforce 570.

When scanning for Freeview channels, the application crashes out, here is the backtrace:

mythtv-setup

X Error: BadDevice?, invalid or uninitialized input device 169

Major opcode: 147 Minor opcode: 3 Resource id: 0x0

Failed to open device X Error: BadDevice?, invalid or uninitialized input device 169

Major opcode: 147 Minor opcode: 3 Resource id: 0x0

Failed to open device 2007-03-16 02:31:23.192 Using runtime prefix = /usr 2007-03-16 02:31:23.195 DPMS is active. 2007-03-16 02:31:23.216 New DB connection, total: 1 2007-03-16 02:31:23.221 Connected to database 'mythconverg' at host: localhost 2007-03-16 02:31:23.223 Total desktop dim: 2560x1600, with 1 screen[s]. 2007-03-16 02:31:23.226 Using screen 0, 2560x1600 at 0,0 2007-03-16 02:31:23.235 Current Schema Version: 1160 2007-03-16 02:31:23.257 Total desktop dim: 2560x1600, with 1 screen[s]. 2007-03-16 02:31:23.258 Using screen 0, 2560x1600 at 0,0 2007-03-16 02:31:23.261 Switching to square mode (G.A.N.T.) 2007-03-16 02:31:23.281 Using the Qt painter mythtv: could not connect to socket mythtv: No such file or directory lirc_init failed for mythtv, see preceding messages 2007-03-16 02:31:24.153 Joystick disabled. 2007-03-16 02:31:25.280 Loading from: /usr/share/mythtv/themes/G.A.N.T./base.xml 2007-03-16 02:31:25.316 Loading from: /usr/share/mythtv/themes/default/base.xml 2007-03-16 02:32:12.821 New DB connection, total: 2 2007-03-16 02:32:12.822 Connected to database 'mythconverg' at host: localhost 2007-03-16 02:32:12.823 DiSEqCDevTree, Warning: No device tree for cardid 6 2007-03-16 02:32:12.826 New DB connection, total: 3 2007-03-16 02:32:12.826 Connected to database 'mythconverg' at host: localhost 2007-03-16 02:32:12.830 New DB connection, total: 4 2007-03-16 02:32:12.831 Connected to database 'mythconverg' at host: localhost 2007-03-16 02:32:12.832 New DB connection, total: 5 2007-03-16 02:32:12.833 Connected to database 'mythconverg' at host: localhost * glibc detected * mythtv-setup: free(): invalid pointer: 0xb26de74f * ======= Backtrace: ========= /lib/tls/i686/cmov/libc.so.6[0xb5a5e7ad] /lib/tls/i686/cmov/libc.so.6(cfree+0x90)[0xb5a61e10] /usr/lib/libqt-mt.so.3(_ZN7QGArrayD2Ev+0x6f)[0xb64b43d9] /usr/lib/libmythtv-0.20.so.0(_ZN9QMemArrayIcED1Ev+0x2d)[0xb77c171b] /usr/lib/libqt-mt.so.3(_ZN7QBufferD0Ev+0x2e)[0xb649ff84] /usr/lib/libqt-mt.so.3(_ZN11QDataStreamD1Ev+0x4d)[0xb64a902d] /usr/lib/libqt-mt.so.3(_ZNK11QTranslator11findMessageEPKcS1_S1_+0x521)[0xb61aa011] /usr/lib/libqt-mt.so.3(_ZNK12QApplication9translateEPKcS1_S1_NS_8EncodingE+0xb8)[0xb6157a88] /usr/lib/libmythtv-0.20.so.0(_ZN17ScanProgressPopup2trEPKcS1_+0x43)[0xb7c6573f] /usr/lib/libmythtv-0.20.so.0(_ZN17ScanProgressPopup7dvbLockEi+0x6b)[0xb7b01d47] /usr/lib/libmythtv-0.20.so.0(_ZN17ScanWizardScanner11customEventEP12QCustomEvent+0x169)[0xb7b1dae1] /usr/lib/libqt-mt.so.3(_ZN7QObject5eventEP6QEvent+0x119)[0xb61be799] /usr/lib/libqt-mt.so.3(_ZN12QApplication14internalNotifyEP7QObjectP6QEvent+0x274)[0xb61562ec] /usr/lib/libqt-mt.so.3(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x1e9)[0xb615811b] /usr/lib/libmyth-0.20.so.0(_ZN12QApplication9sendEventEP7QObjectP6QEvent+0x54)[0xb6c46e80] /usr/lib/libqt-mt.so.3(_ZN12QApplication16sendPostedEventsEP7QObjecti+0x25c)[0xb6157324] /usr/lib/libqt-mt.so.3(_ZN12QApplication16sendPostedEventsEv+0x26)[0xb615742c] /usr/lib/libqt-mt.so.3(_ZN10QEventLoop13processEventsEj+0x65)[0xb60fc40d] /usr/lib/libqt-mt.so.3(_ZN10QEventLoop9enterLoopEv+0x70)[0xb61709c2] /usr/lib/libqt-mt.so.3(_ZN12QApplication10enter_loopEv+0x25)[0xb6157e13] /usr/lib/libmyth-0.20.so.0(_ZN10MythDialog4execEv+0x7d)[0xb6be217f] /usr/lib/libmyth-0.20.so.0(_ZN19ConfigurationDialog4execEbb+0xa4)[0xb6b5bb52] /usr/lib/libmythtv-0.20.so.0(_ZN9CardInput14channelScannerEv+0x3de)[0xb776a98c] /usr/lib/libmythtv-0.20.so.0(_ZN9CardInput9qt_invokeEiP8QUObject+0x4f)[0xb7c44ac7] /usr/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEP15QConnectionListP8QUObject+0x12f)[0xb61bf097] /usr/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEi+0x162)[0xb61bfb3c] /usr/lib/libmyth-0.20.so.0(_ZN13ButtonSetting7pressedEv+0x40)[0xb6c7df0c] /usr/lib/libmyth-0.20.so.0(_ZN13ButtonSetting7qt_emitEiP8QUObject+0x4d)[0xb6c7e967] /usr/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEP15QConnectionListP8QUObject+0x230)[0xb61bf198] /usr/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEi+0x162)[0xb61bfb3c] /usr/lib/libqt-mt.so.3(_ZN7QButton7pressedEv+0x2e)[0xb6554b40] /usr/lib/libmyth-0.20.so.0(_ZN14MythPushButton13keyPressEventEP9QKeyEvent+0x140)[0xb6b4c816] /usr/lib/libqt-mt.so.3(_ZN7QWidget5eventEP6QEvent+0x315)[0xb61f608b] /usr/lib/libqt-mt.so.3(_ZN12QApplication14internalNotifyEP7QObjectP6QEvent+0x274)[0xb61562ec] /usr/lib/libqt-mt.so.3(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x38a)[0xb61582bc] /usr/lib/libqt-mt.so.3(_ZN12QApplication20sendSpontaneousEventEP7QObjectP6QEvent+0x5b)[0xb60e83dd] /usr/lib/libqt-mt.so.3(_ZN9QETWidget17translateKeyEventEPK7_XEventb+0xb83)[0xb60d8da9] /usr/lib/libqt-mt.so.3(_ZN12QApplication15x11ProcessEventEP7_XEvent+0xc7f)[0xb60e51af] /usr/lib/libqt-mt.so.3(_ZN10QEventLoop13processEventsEj+0x108)[0xb60fc4b0] /usr/lib/libqt-mt.so.3(_ZN10QEventLoop9enterLoopEv+0x70)[0xb61709c2] /usr/lib/libqt-mt.so.3(_ZN12QApplication10enter_loopEv+0x25)[0xb6157e13] /usr/lib/libmyth-0.20.so.0(_ZN10MythDialog4execEv+0x7d)[0xb6be217f] /usr/lib/libmyth-0.20.so.0(_ZN19ConfigurationDialog4execEbb+0xa4)[0xb6b5bb52] /usr/lib/libmythtv-0.20.so.0(_ZN15CardInputEditor4execEv+0x82)[0xb775e8f2] mythtv-setup[0x80772e6] /usr/lib/libmythui-0.20.so.0(_ZN21MythThemedMenuPrivate12handleActionERK7QString+0x11c6)[0xb6a03bbe] /usr/lib/libmythui-0.20.so.0(_ZN21MythThemedMenuPrivate10keyHandlerER11QStringListb+0x542)[0xb6a0411a] /usr/lib/libmythui-0.20.so.0(_ZN21MythThemedMenuPrivate15keyPressHandlerEP9QKeyEvent+0xb2)[0xb6a048b4] /usr/lib/libmythui-0.20.so.0(_ZN14MythThemedMenu13keyPressEventEP9QKeyEvent+0x55)[0xb6a04957] /usr/lib/libmythui-0.20.so.0(_ZN14MythMainWindow11eventFilterEP7QObjectP6QEvent+0x1cc)[0xb69b8ad4] /usr/lib/libqt-mt.so.3(_ZN7QObject16activate_filtersEP6QEvent+0x78)[0xb61be644] /usr/lib/libqt-mt.so.3(_ZN7QObject5eventEP6QEvent+0x42)[0xb61be6c2] /usr/lib/libqt-mt.so.3(_ZN7QWidget5eventEP6QEvent+0x25)[0xb61f5d9b] /usr/lib/libqt-mt.so.3(_ZN12QApplication14internalNotifyEP7QObjectP6QEvent+0x274)[0xb61562ec] /usr/lib/libqt-mt.so.3(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x38a)[0xb61582bc] /usr/lib/libqt-mt.so.3(_ZN12QApplication20sendSpontaneousEventEP7QObjectP6QEvent+0x5b)[0xb60e83dd] /usr/lib/libqt-mt.so.3(_ZN9QETWidget17translateKeyEventEPK7_XEventb+0xb83)[0xb60d8da9] /usr/lib/libqt-mt.so.3(_ZN12QApplication15x11ProcessEventEP7_XEvent+0xc7f)[0xb60e51af] /usr/lib/libqt-mt.so.3(_ZN10QEventLoop13processEventsEj+0x108)[0xb60fc4b0] /usr/lib/libqt-mt.so.3(_ZN10QEventLoop9enterLoopEv+0x70)[0xb61709c2] /usr/lib/libqt-mt.so.3(_ZN10QEventLoop4execEv+0x32)[0xb61707d2] /usr/lib/libqt-mt.so.3(_ZN12QApplication4execEv+0x25)[0xb6157e95] mythtv-setup[0x807496d] ======= Memory map: ======== 08048000-0808c000 r-xp 00000000 08:01 14885728 /usr/bin/mythtv-setup 0808c000-0808d000 rw-p 00044000 08:01 14885728 /usr/bin/mythtv-setup 0808d000-0835c000 rw-p 0808d000 00:00 0 [heap] 9b4ff000-9b500000 ---p 9b4ff000 00:00 0 9b500000-9bd00000 rwxp 9b500000 00:00 0 9bd00000-9bd21000 rw-p 9bd00000 00:00 0 9bd21000-9be00000 ---p 9bd21000 00:00 0 9be16000-9be1d000 r-xp 00000000 08:01 57950370 /lib/tls/i686/cmov/libnss_compat-2.5.so 9be1d000-9be1f000 rw-p 00006000 08:01 57950370 /lib/tls/i686/cmov/libnss_compat-2.5.so 9be2f000-9be75000 r--p 00000000 08:01 53805132 /usr/share/fonts/truetype/msttcorefonts/Arial_Bold.ttf 9be75000-b15e3000 rw-p 9be75000 00:00 0 b1661000-b16e2000 rw-p b1661000 00:00 0 b16e2000-b17b6000 r-xp 00000000 08:01 14884410 /usr/lib/libscim-1.0.so.8.1.0 b17b6000-b17c4000 rw-p 000d4000 08:01 14884410 /usr/lib/libscim-1.0.so.8.1.0 b17c4000-b2621000 rw-p b17c4000 00:00 0 b2664000-b2666000 r-xp 00000000 08:01 14884411 /usr/lib/libscim-x11utils-1.0.so.8.1.0 b2666000-b2667000 rw-p 00001000 08:01 14884411 /usr/lib/libscim-x11utils-1.0.so.8.1.0 b2677000-b2695000 r-xp 00000000 08:01 15061944 /usr/lib/qt3/plugins/inputmethods/libqscim.so b2695000-b2696000 rw-p 0001e000 08:01 15061944 /usr/lib/qt3/plugins/inputmethods/libqscim.so b2696000-b26a1000 r-xp 00000000 08:01 15057860 /usr/lib/qt3/plugins/inputmethods/libqxim.so b26a1000-b26a2000 rw-p 0000a000 08:01 15057860 /usr/lib/qt3/plugins/inputmethods/libqxim.so b26a2000-b26c6000 r-xp 00000000 08:01 15057859 /usr/lib/qt3/plugins/inputmethods/libqsimple.so b26c6000-b26c7000 rw-p 00024000 08:01 15057859 /usr/lib/qt3/plugins/inputmethods/libqsimple.so b26c7000-b26d0000 r-xp 00000000 08:01 15057857 /usr/lib/qt3/plugins/inputmethods/libqimsw-multi.so b26d0000-b26d1000 rw-p 00009000 08:01 15057857 /usr/lib/qt3/plugins/inputmethods/libqimsw-multi.so b26d1000-b26d9000 r-xp 00000000 08:01 57950375 /lib/tls/i686/cmov/libnss_nis-2.5.so b26d9000-b26db000 rw-p 00007000 08:01 57950375 /lib/tls/i686/cmov/libnss_nis-2.5.so b26db000-b26df000 r--p 00000000 08:01 15354199 /usr/share/mythtv/i18n/mythfrontend_en_gb.qm b26df000-b275c000 r--p 00000000 08:01 14926723 /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans.ttf b275c000-b275d000 ---p b275c000 00:00 0 b275d000-b2f5d000 rwxp b275d000 00:00 0 b2f5d000-b2f5e000 ---p b2f5d000 00:00 0 b2f5e000-b375e000 rwxp b2f5e000 00:00 0 b375e000-b375f000 rw-s 00000000 00:08 1146882 /SYSV00000000 (deleted) b375f000-b3760000 rw-s 00000000 00:08 1114113 /SYSV00000000 (deleted) b3760000-b37a0000 rw-s effbe000 00:0d 14247 /dev/nvidia0 b37a0000-b38a0000 rw-s 36455000 00:0d 14247 /dev/nvidia0 b38a0000-b39a2000 rw-s 3734e000 00:0d 14247 /dev/nvidia0 b39a2000-b39cc000 r-xp 00000000 08:01 14882322 /usr/lib/libkdefx.so.4.2.0 b39cc000-b39cd000 rw-p 0002a000 08:01 14882322 /usr/lib/libkdefx.so.4.2.0 b39cd000-b39f5000 r-xp 00000000 08:01 15078819 /usr/lib/kde3/plugins/styles/polyester.so b39f5000-b39f6000 rw-p 00028000 08:01 15078819 /usr/lib/kde3/plugins/styles/polyester.so b39f6000-b3a20000 r-xp 00000000 08:01 14882135 /usr/lib/liblcms.so.1.0.15 b3a20000-b3a21000 rw-p 00029000 08:01 14882135 /usr/lib/liblcms.so.1.0.15 b3a21000-b3a24000 rw-p b3a21000 00:00 0 b3a24000-b3a8f000 r-xp 00000000 08:01 14882137 /usr/lib/libmng.so.1.1.0.9 b3a8f000-b3a92000 rw-p 0006a000 08:01 14882137 /usr/lib/libmng.so.1.1.0.9 b3a92000-b3a97000 r-xp 00000000 08:01 15057855 /usr/lib/qt3/plugins/imageformats/libqmng.so b3a97000-b3a98000 rw-p 00004000 08:01 15057855 /usr/lib/qt3/plugins/imageformats/libqmng.so b3a98000-b3ad9000 rw-p b3a98000 00:00 0 b3ad9000-b3b3e000 rw-p 00000000 00:0d 2665 /dev/zero b3b3f000-b4adf000 rw-s e0000000 00:0d 14247 /dev/nvidia0 b4adf000-b4b00000 rw-p b4adf000 00:00 0 b4b00000-b4b26000 rw-s 00000000 00:08 0 /SYSV00000000 (deleted) b4b26000-b4b6a000 r--p 00000000 08:01 53805134 /usr/share/fonts/truetype/msttcorefonts/Arial.ttf b4b6aAborted (core dumped)

Change History (2)

comment:1 Changed 13 years ago by tominglis@…

Do let me know if there is any other info that you need! It would be amazing if you could fix this? I saw a number of people have this problem too via Google.

comment:2 Changed 13 years ago by Janne Grunau

Resolution: duplicate
Status: newclosed

probably a duplicate of #2735

Note: See TracTickets for help on using tickets.