Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#328 closed defect (fixed)

mpegts_read_header: could not find service

Reported by: JTK Owned by: danielk
Priority: major Milestone: 0.19
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I use Mythtv with 3 Inputs: DVB-T, Analog and a DBOX. If i use the DBOX as Source the most works fine, but if i try to watch or record ZDF,ZDFdokukanal,ZDFinfokanal get this Error : mpegts_read_header: could not find service 2005-09-13 01:12:07.211 AvFormatDecoder?: avformat error (-1) on av_open_input_file call. The Backend write a nuv-File , and i can see it correctly with MPlayer 1.0pre7try2-3.4.5. I will try to attachev File.

Grettings

JTK

Attachments (6)

17442_20050913003900_20050913004300.nuv.gz (233.9 KB) - added by JTK 14 years ago.
frontlog.gz (10.7 KB) - added by JTK 14 years ago.
backlog.gz (6.3 KB) - added by JTK 14 years ago.
backend.log (51.7 KB) - added by anonymous 14 years ago.
frontend.log (72.9 KB) - added by anonymous 14 years ago.
dbox2-fix.patch (2.9 KB) - added by danielk 14 years ago.
dbox2 fix

Download all attachments as: .zip

Change History (19)

Changed 14 years ago by JTK

comment:1 Changed 14 years ago by JTK

Sorry, i forget, i am using the CVS-Branch = 7237

comment:2 Changed 14 years ago by danielk

Resolution: invalid
Status: newclosed

This was a secondary error for something that should be fixed now, i.e. DVB tuning problems.

I would have also needed the backend and frontend logs with '-v record,channel,siparser' and '-v playback' respectively to fix this...

Changed 14 years ago by JTK

Attachment: frontlog.gz added

Changed 14 years ago by JTK

Attachment: backlog.gz added

comment:3 Changed 14 years ago by JTK

Resolution: invalid
Status: closedreopened

I have attached the Files. I hope this helps. I am running at the Moment CVS=7270.

regards

JTK

comment:4 Changed 14 years ago by danielk

Owner: changed from Isaac Richards to danielk
Status: reopenednew

Can you try again with the latest SVN?

I'll need new logs if it still doesn't work.

comment:5 Changed 14 years ago by danielk

Resolution: worksforme
Status: newclosed

No reply to request for logs, closing as "works for me".

comment:6 Changed 14 years ago by JTK

Resolution: worksforme
Status: closedreopened

Sorry was on vaction. It works not with revision 7431. I have attached the requested files.

Greetings

Changed 14 years ago by anonymous

Attachment: backend.log added

Changed 14 years ago by anonymous

Attachment: frontend.log added

Changed 14 years ago by danielk

Attachment: dbox2-fix.patch added

dbox2 fix

comment:7 Changed 14 years ago by danielk

Can you try the dbox2-fix.patch?

It waits for a DBox2Channel::ChannelChanged?() signal before telling SetChannel?() it is safe to return.

It looks like the problem is that the DBox2 is taking a long time to change channels, but doesn't have signal monitoring support like the DVB and HDTV recorders so there is no DummyDTVRecorder. Eventually the recording starts, but by then the frontend has given up and tells the backend to quit the recording.

comment:8 Changed 14 years ago by JTK

I have tried the Patch and the last revision and the Problem is not fixed :-( I can record the Program, but i can only watch it if i using the mplayer. BTW This Errors are only present if i try to watch ZDF. ARD works fine with Mythtv and the dbox !?

comment:9 Changed 14 years ago by danielk

Can you find out what the delay is between the channel change and when the file begins filling up with data, and can you tell me if scheduled (i.e. non-LiveTV) recordings work on ZDF (i.e. can you record and play them back later in MythTV?

Also can you play the recorded file with this?:

mythtv filename.mpg

Where filename.mpg is the name of the recorded file.

comment:10 Changed 14 years ago by danielk

Hmm, it looks like if you set the MAX_SCAN_PACKETS to 1000 in lib/libavformat/mpegts.c then you can view the file you attached. But of course this breaks LiveTV for the DVB recorder, so it is not a workable solution.

However it may point to the problem, I think some of the broken MPEG-TS code from ffmpeg may have made it back into MythTV's ffmpeg in one of the ffmpeg resyncs. I'll look through the file history for something that sticks out. My first guess would be something in the PAT table handling went awry.

comment:11 Changed 14 years ago by JTK

I will check this tonight

comment:12 Changed 14 years ago by danielk

Resolution: fixed
Status: reopenedclosed

(In [7502]) Fixes #328.

This fixes a problem in mpegts.c wrt PAT scanning, the old code assumed that every PAT seen was brand new so it tossed out everything we knew. And it also didn't add services to the services list, so that list became stale quite quickly. This merges the pat_scan_cb with pat_cb, so that we now add services to that list. (I left the pat_scan_cb function alone (and unused) for ease of ffmpeg merging.)

This PAT issue isn't a problem with the MythTV DVB & HDTV TS streams because we always use the same program number of "1". But this is a problem with general TS streams.

I've also added another PMT searching pass, for when we fail to find a PMT in the stream the first time. This pass looks for the same PMT, but without the CRC check. This lets us play back mangled "ZDF" streams from the DBOX2 in Germany.

comment:13 Changed 14 years ago by JTK

Super, thank you very much

Note: See TracTickets for help on using tickets.