Opened 13 years ago

Closed 13 years ago

#3308 closed defect (fixed)

Mythmusic errors when using jump point from rip cd screen

Reported by: anonymous Owned by: paulh
Priority: minor Milestone: unknown
Component: mythmusic Version: head
Severity: medium Keywords: error jump point mythmusic rip
Cc: Ticket locked: no

Description

Mythmusic has an unrecoverable error when exiting the rip cd screen using the jump point to main menu. It just hangs looking like it is trying to paint a popup of some sort. I have a -v all log, but it doesn't show anything interesting, I last tried with r13224.

Change History (3)

comment:1 Changed 13 years ago by anonymous

Some further information. I performed a "svn update -r12708" from within the mythmusic subdirectory of the mythplugins source tree and then compiled and installed the mythmusic. I still experienced the problem with exiting the new rip cd screen using a jump point.

I haven't been able to recompile the whole source tree due to time constraints, but I will try to (unless someone can confirm just regressing mythmusic is OK).

So were to from here?

Should I try to place some debug messages in the source... I might try and hack this if I can as I am no programmer.

comment:2 Changed 13 years ago by paulh

Owner: changed from Isaac Richards to paulh

I can reproduce this one. I'll see what I can do to fix it.

comment:3 Changed 13 years ago by paulh

Resolution: fixed
Status: newclosed

(In [13272]) On the main rip music screen don't try to eject the CD if we're exiting the screen as a result of a jump point being activated because the Eject CD progress dialog causes problems. The CD will still be ejected if you exit the dialog by pressing ESCAPE.

Disable jump points completely in the music rip status screen. You most definitely don't want to jump to another screen while ripping a CD.

Fixes #3308.

Note: See TracTickets for help on using tickets.