Opened 13 years ago

Closed 11 years ago

Last modified 11 years ago

#3322 closed patch (fixed)

Mythwelcome spuriously quits under session management

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords: easy
Cc: Ticket locked: no

Description

If, under gnome on Ubuntu Edgy, you start mythwelcome and it immediately starts mythfrontend, then several minutes (or hours) later quit the front end, mythwelcome will also immediately quit. I have tracked this down to the way session management works -- mythwelcome opens the session manager connection, but because it is running mythfrontend, never services the socket. So the initial SAVE_STATE message times out, which gnome-session responds to by removing mythwelcome from the session. When mythfrontend quits, mythwelcome receives a "die" callback as soon as it services the socket, and dutifully quits.

One workaround is to run mythwelcome without session management,

Attachments (1)

svn-3222-patch (512 bytes) - added by anonymous 11 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 13 years ago by mrussotto@…

Err, hit send a bit prematurely.

One workaround is to run mythwelcome without session management, by clearing the SESSION_MANAGER variable or setting it to the empty string.

comment:2 Changed 13 years ago by paulh

Resolution: wontfix
Status: newclosed

Can you not just start MythWelcome? from a script that unset's the SESSION_MANAGER variable?

I don't use gnome so have no interest in fixing this but if you can come up with a better fix then re-open the ticket with a patch and I will take a look.

comment:3 Changed 11 years ago by laga

Resolution: wontfix
Status: closednew

Changed 11 years ago by anonymous

Attachment: svn-3222-patch added

comment:4 in reply to:  3 Changed 11 years ago by alrcan@…

Replying to laga:

patch attached.

Sorry for delay, needed to do a clean svn co, build & retest without some debug code I had in my working copy.

Alan

comment:5 Changed 11 years ago by laga

Keywords: easy added
Type: defectpatch

comment:6 Changed 11 years ago by paulh

Resolution: fixed
Status: newclosed

(In [18671]) Fix a problem with MythWelcome? running under Gnome.

Sometimes the Gnome session manager would think MythWelcome? had crashed when it was just waiting for MythFrontend to exit. We just delay starting MythFrontend at start up slightly so MythWelcome?'s event queue has a chance to run before running the FE which is apparently enough to keep the Gnome session manager happy.

Thanks to alrcan (at) blueyonder.co.uk for tracking this down and the patch. Fixes #3322.

comment:7 Changed 11 years ago by anonymous

Please backport to 0.21-fixes.

comment:8 Changed 11 years ago by r@…

Pretty please, can someone take the time and backport this to 0.21-fixes. The problem is hitting me badly everyday on Mythbuntu. It makes my ACPI wakeup system behave badly and backport is so simple, so please please :)

comment:9 Changed 11 years ago by anonymous

Yes, a backport to 0.21-fixes would be greatly appreciated.

Note: See TracTickets for help on using tickets.